summaryrefslogtreecommitdiff
path: root/dev-python/pyprof2calltree
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyprof2calltree
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyprof2calltree')
-rw-r--r--dev-python/pyprof2calltree/Manifest4
-rw-r--r--dev-python/pyprof2calltree/files/pyprof2calltree-1.4.0-py3-test.patch30
-rw-r--r--dev-python/pyprof2calltree/metadata.xml11
-rw-r--r--dev-python/pyprof2calltree/pyprof2calltree-1.4.0.ebuild26
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/pyprof2calltree/Manifest b/dev-python/pyprof2calltree/Manifest
new file mode 100644
index 000000000000..ada61141262f
--- /dev/null
+++ b/dev-python/pyprof2calltree/Manifest
@@ -0,0 +1,4 @@
+AUX pyprof2calltree-1.4.0-py3-test.patch 895 BLAKE2B 23fc01e9c0657b26ebf061bb8e42b966e35bf73190d8d46c3822a04a5f4f637448307924e4e89274ba809661c330c7b4c7ea58b85d81977857fc21a724e217ed SHA512 26f55492e65f8708c0587c594ae05a4ffe2611debe1dacabfa6b959468c02ae5e3c4b8ca0a86fc8f23be1646aef83b9450468483f7f40a8f746e026dac0b70db
+DIST pyprof2calltree-1.4.0.tar.gz 7784 BLAKE2B e8b9ecd857930406bb3b7f7851913a68f1e3433f3b42c262922b5d5b0fbfa692078fdad811d4ca358f7c74d14320c914cfa779ed0b9da8c4fcd7d8e021fd3319 SHA512 b1acba29cd4e5112012eeeffdac53900688a28707306ef3a8a3827f7422c35bc921d59d33db3209db923bb8640014e7d9d7d819eafbcb19e0cf7e6159537bded
+EBUILD pyprof2calltree-1.4.0.ebuild 675 BLAKE2B b4f2f20454eab98d78974ed7bc1f2e0f0fbe29c4ca8a6a92a447d6511dadf52bd3eb3ab7d02332a03aefb30e0199955409ef8d286b063a4a7e53304d18d6b978 SHA512 fccf70cc1c192c6d939d10e5cb4c964619ce85185b579bd28d7ef1532fb9b08b2b368fa80aa9f8cc96b9f0cb978f0e9b7221b0b6bb09a0b35ccf6f45ef384b28
+MISC metadata.xml 318 BLAKE2B 9a8c3c56c2987bb1de47d374f81d25eee0aec15c00432bfd1585dadd5c57aae4ba8453739ad12dbcb8b44c54de4c5042a41da9458585387e1000ec6e97b9a267 SHA512 7a75d6efb9f11a6e1ce086cf53e5038b12815fe8110bf16c9b6e781c31cb721ec8694fb6fb0d4d131f9581cb130cecbceadf0e10b1528717cb8f4ab977514372
diff --git a/dev-python/pyprof2calltree/files/pyprof2calltree-1.4.0-py3-test.patch b/dev-python/pyprof2calltree/files/pyprof2calltree-1.4.0-py3-test.patch
new file mode 100644
index 000000000000..a91818fca60c
--- /dev/null
+++ b/dev-python/pyprof2calltree/files/pyprof2calltree-1.4.0-py3-test.patch
@@ -0,0 +1,30 @@
+From 582eeeaa930639ccfe9b789b057f170824edd73a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Wed, 17 May 2017 20:53:29 +0200
+Subject: [PATCH] tests: Fix StringIO import for Python 3
+
+Python 3 no longer provides a 'cStringIO' module. Use StringIO from 'io'
+module instead.
+---
+ tests/test_integration.py | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/tests/test_integration.py b/tests/test_integration.py
+index e6f432c..cf02a4f 100644
+--- a/tests/test_integration.py
++++ b/tests/test_integration.py
+@@ -3,7 +3,10 @@ import pstats
+ import unittest
+
+ from .profile_code import top, expected_output
+-from cStringIO import StringIO
++try:
++ from cStringIO import StringIO
++except ImportError:
++ from io import StringIO
+ from pyprof2calltree import CalltreeConverter
+
+ class MockTimeProfile(cProfile.Profile):
+--
+2.13.0
+
diff --git a/dev-python/pyprof2calltree/metadata.xml b/dev-python/pyprof2calltree/metadata.xml
new file mode 100644
index 000000000000..ae7e9c912476
--- /dev/null
+++ b/dev-python/pyprof2calltree/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyprof2calltree</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyprof2calltree/pyprof2calltree-1.4.0.ebuild b/dev-python/pyprof2calltree/pyprof2calltree-1.4.0.ebuild
new file mode 100644
index 000000000000..c7ce811bf4ad
--- /dev/null
+++ b/dev-python/pyprof2calltree/pyprof2calltree-1.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="convert python profile data to kcachegrind calltree form"
+HOMEPAGE="https://pypi.org/project/pyprof2calltree/"
+# pypi tarball lacks tests
+SRC_URI="https://github.com/pwaller/pyprof2calltree/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/pyprof2calltree-1.4.0-py3-test.patch
+)
+
+python_test() {
+ "${PYTHON}" -m tests.test_integration || die "Tests fail with ${EPYTHON}"
+}