summaryrefslogtreecommitdiff
path: root/dev-python/pyprof2calltree
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pyprof2calltree
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pyprof2calltree')
-rw-r--r--dev-python/pyprof2calltree/Manifest2
-rw-r--r--dev-python/pyprof2calltree/pyprof2calltree-1.4.5-r1.ebuild (renamed from dev-python/pyprof2calltree/pyprof2calltree-1.4.5.ebuild)9
2 files changed, 6 insertions, 5 deletions
diff --git a/dev-python/pyprof2calltree/Manifest b/dev-python/pyprof2calltree/Manifest
index aea6eee24996..fb7fa4fc0597 100644
--- a/dev-python/pyprof2calltree/Manifest
+++ b/dev-python/pyprof2calltree/Manifest
@@ -1,3 +1,3 @@
DIST pyprof2calltree-1.4.5.tar.gz 8806 BLAKE2B 3a8a838a8b03294504c64dbe1d0caee2606a1ec53005222dfe6c3692bacd0801041ce199fedb9c38e4f6edc91e210116d9c1e034e0aa283cafebb19bf6303fed SHA512 2fcda74ae67dc3a8abb5dc153864ef59f96cc62b1c9359d02be12e83966c17738f5aa4a3d1c6e2ff81614dc963fc4b2faf375bbbb1ad15650a6817e493cdde39
-EBUILD pyprof2calltree-1.4.5.ebuild 490 BLAKE2B 759af98d2a74f670f1b34a1181aa2a02eea56eff80b58cc4616beb16c35243930925ca409fa4c020240742822858f261cfed5ad1f88ecc81ffb02846f0be5475 SHA512 b3426f0112284cec6d11ecf5c2373a4bd12ae0f52389c669a7ec5dcf3ad5e7ddf6af71c4bef6b67ec8f56aa7f1a1f558aea0786619d452aca6e826a7b4af5ca6
+EBUILD pyprof2calltree-1.4.5-r1.ebuild 522 BLAKE2B c6fafcc988c7aa46422905644d70941d582f5e94a01104ca3e94ffaf09b537b49b6a6afc2e442ad89ad1740b952d6219b80daad2c38d23f344cb91ee59da5ad5 SHA512 c2d9dedf97e5a2b5bdc0db5d2c0f73166d93b34de0a525f8c2be1905f377549951e81e4c79df4de7eea969acbf28abd3c3824d574c21ded24792026d1a77e13a
MISC metadata.xml 406 BLAKE2B 7d3e2257b0a06747c1772ff90ac2375467633f40d7b4064389e64aaf426b07d5ea263098115a96ce035f200d55c9e83049ef7df0812a585ff7dd9a86407db832 SHA512 ff6a0e3b75a157ad85bcd1e75dc277849b67379bb097e4ba0b2373247456cfcbc079d36f7cdde266669bf2db99eb63a471d3ab156e1218628db3b1b51abf43d4
diff --git a/dev-python/pyprof2calltree/pyprof2calltree-1.4.5.ebuild b/dev-python/pyprof2calltree/pyprof2calltree-1.4.5-r1.ebuild
index a979232643d7..dd5ed079c2b3 100644
--- a/dev-python/pyprof2calltree/pyprof2calltree-1.4.5.ebuild
+++ b/dev-python/pyprof2calltree/pyprof2calltree-1.4.5-r1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="convert python profile data to kcachegrind calltree form"
@@ -15,4 +16,4 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-distutils_enable_tests setup.py
+distutils_enable_tests unittest