summaryrefslogtreecommitdiff
path: root/dev-python/pyperclip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pyperclip
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pyperclip')
-rw-r--r--dev-python/pyperclip/Manifest3
-rw-r--r--dev-python/pyperclip/metadata.xml14
-rw-r--r--dev-python/pyperclip/pyperclip-1.5.27.ebuild19
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pyperclip/Manifest b/dev-python/pyperclip/Manifest
new file mode 100644
index 000000000000..800f389c2ba0
--- /dev/null
+++ b/dev-python/pyperclip/Manifest
@@ -0,0 +1,3 @@
+DIST pyperclip-1.5.27.zip 16938 SHA256 a3cb6df5d8f1557ca8fc514d94fabf50dc5a97042c90e5ba4f3611864fed3fc5 SHA512 cefd79f1d246c9aa9d4d0f3d8cdad291ad31bcc2e000c83e5e05704978bbf7b9b45d49667c2e88305d0a5d6baaeacfb47b26bb69fabf89b6b6e3a1e6f1e23d74 WHIRLPOOL e06951b934afcf16e26588d0bbcc018204b5a941065cd2871ee45a94cd0d2f54967aa0d7e6798b92aa5c64c37e4d7d246eba6bacd42c8b6aec9e4e6d9d3669be
+EBUILD pyperclip-1.5.27.ebuild 480 SHA256 a05f4b60ae3855d1d0ac703ec3abf184e182464855b6caa9e280b07b061f4a66 SHA512 6c5578da9d8733d3136bdcc3e06b31310197ac289636c9f698b40a8e1009616c0743948e99c77c22bb417ae1239416d2019dad5a682b476aba4ddb93fdb6ea4d WHIRLPOOL ff238275a1bbea7ed2b666455cc142cb14a8cf159154bb8ba1ca76f92cd4156153be8fe5e88890f3225423ba0e2009a6ae67babf87c4b2b044cc0997785c8854
+MISC metadata.xml 430 SHA256 d0d2862d09599ab5a8cdc0ca3f9c8887b884586888ce000c0c84a4cbef5efbe2 SHA512 883b80ca383707db508144d0434f091827e1809c9029a380c9369f8f98d920e69653767e9034eadeb730611601a0fbf09a222a45e015e08ef95c7fb54158d228 WHIRLPOOL 99e2c2cd8e833ae0fd3276051272e3315794f637893e1790e38147538b2880af1ce3b62a67d9c96e65eea17c610bb7e6b0597a8082339ced813bef0d77366cd6
diff --git a/dev-python/pyperclip/metadata.xml b/dev-python/pyperclip/metadata.xml
new file mode 100644
index 000000000000..364c5c198e73
--- /dev/null
+++ b/dev-python/pyperclip/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ A cross-platform clipboard module for Python.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pyperclip/pyperclip-1.5.27.ebuild b/dev-python/pyperclip/pyperclip-1.5.27.ebuild
new file mode 100644
index 000000000000..c7870d061ee6
--- /dev/null
+++ b/dev-python/pyperclip/pyperclip-1.5.27.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 pypy)
+inherit distutils-r1
+
+DESCRIPTION="A cross-platform clipboard module for Python."
+HOMEPAGE="https://github.com/asweigart/pyperclip"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""