summaryrefslogtreecommitdiff
path: root/dev-python/pypdf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-29 03:04:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-10-29 03:04:53 +0000
commitbd35a61d88b111f25f4b10126e0d4755545fc7a5 (patch)
tree656ac661ed7b28ad66ba778b74bc5fe4e2b86b10 /dev-python/pypdf
parent5d4291ee2ba8b85e8515b5f47b814a5c872eed04 (diff)
gentoo auto-resync : 29:10:2024 - 03:04:53
Diffstat (limited to 'dev-python/pypdf')
-rw-r--r--dev-python/pypdf/Manifest2
-rw-r--r--dev-python/pypdf/pypdf-5.1.0.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/pypdf/Manifest b/dev-python/pypdf/Manifest
index cddab00485c4..d9798cc147c6 100644
--- a/dev-python/pypdf/Manifest
+++ b/dev-python/pypdf/Manifest
@@ -1,4 +1,6 @@
DIST pypdf-5.0.1.gh.tar.gz 8014103 BLAKE2B 27b7533e56e87b0945058a05aaf6079d7259705c01d4d8601e46b1c5947918d155664250cc5339afe3a3a4cc926abfb34502a7048aba91d67b2bf3661169df72 SHA512 3109164a5fbcb03c397e371802dd8502f78ed31acf38fdf7cf25be959427614ba0cb05662bc7791d8017fa4adb9438e7bba6190266759286f7a82e5618718023
+DIST pypdf-5.1.0.gh.tar.gz 8026822 BLAKE2B 068490ced3dd97d7c08fe87620b68a7363900ea4b9875b52ea525263ba9240b9ce07f1e98c2fe13167c8f9aa58f9a4280b4eb2ef899ef54efa58a8c1ce02f38c SHA512 2c13b0622fcad1faaee41e82489d12f9f2006822487412eda6108bbec68b37bfc2e94510f29eb0f3a9af788c5d99142fd64f28ed3e464ff17dbecad0442dfd2e
DIST pypdf-sample-files-8c405ece5eff12396a34a1fae3276132002e1753.gh.tar.gz 11748093 BLAKE2B c5989200893b28a3c2062bb024a5cfc6f3389dc259ec129857979fa43469e1274559612b4d555499e2c7e16cf34be07825229932bf4d147fa6d7324d043e97d5 SHA512 c9771129b7668a2fd1fa79bb859ae9213f3d60341cf1b9937ff0eaab0de9bf4c35adcb7b896e93329038dc0f3809a0c697c523f8fe41b43030b0b029a88058e3
EBUILD pypdf-5.0.1.ebuild 1660 BLAKE2B 3f48ae6da3e588de31a32bac9b5a49d3ce935b76422faecd90a859096511a76725f8569fdbd72e4b91f466387f1814e63e3638f6275ce7b4dc13f58a17a03992 SHA512 2e735e20eb7b4491d47998b1724b4ca8abe00de2096d50646f9b900c7b30fa154bbdc8e1bf16d02ed2618da32bd46a9e01c97294bd5c4c0103ee00e4fd2a2161
+EBUILD pypdf-5.1.0.ebuild 1663 BLAKE2B c7d25ba9e7ef1578cf759f515c8ca6f03fc346126dc5e517845877e31a8b60d61e19c4997c88809b9854928c330940910ece7f4170e2dfa60a6cc1e593fe66b8 SHA512 a555afa14553ac27444b904c4f6842c02f70de6b5321ad198ae75d5ee00d83d30768eaaffa8c1c96dfe26d8784adc6133e9dfc6f7f0d8c42338295745e8d8c74
MISC metadata.xml 373 BLAKE2B a829b7048eb3a95caeb1be83b6172603df6a031d40995294f2687bf3c3cb70e66fafb9ba8339d9979fc85f5936b9552963a8fcd072a20661fa78f3aa3c4b89c0 SHA512 775ac2de487f11fba1ea8d283b42b9ef56e42cd95ea11f50a06b099420e69c0567f65c506b14891ac641da90ea05ca70da4f8a3e4a028cf41bdbc823021dccfe
diff --git a/dev-python/pypdf/pypdf-5.1.0.ebuild b/dev-python/pypdf/pypdf-5.1.0.ebuild
new file mode 100644
index 000000000000..86a783051785
--- /dev/null
+++ b/dev-python/pypdf/pypdf-5.1.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+SAMPLE_COMMIT=8c405ece5eff12396a34a1fae3276132002e1753
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/pypdf/
+ https://github.com/py-pdf/pypdf/
+"
+SRC_URI="
+ https://github.com/py-pdf/pypdf/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
+ -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
+ )
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.0.0[jpeg,jpeg2k,tiff,zlib,${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_unpack() {
+ default
+ if use test; then
+ mv "sample-files-${SAMPLE_COMMIT}"/* "${S}"/sample-files/ || die
+ fi
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/test_reader.py::test_decode_permissions
+ tests/test_workflows.py::test_text_extraction_layout_mode
+ # rely on -Werror
+ tests/test_utils.py::test_deprecate_no_replacement
+ tests/test_workflows.py::test_orientations
+ tests/test_writer.py::test_remove_image_per_type
+ tests/test_generic.py::test_name_object
+ # Internet
+ tests/test_generic.py::test_calling_indirect_objects
+ tests/test_writer.py::test_increment_writer
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -m "not enable_socket"
+}