summaryrefslogtreecommitdiff
path: root/dev-python/pypdf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-08 06:31:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-08 06:31:00 +0100
commit102dc42fae2907037d3ca9a6d63ed28e46c5b88e (patch)
tree5302a53ecdd7408812596fcbd8cbaa90bd8e6c98 /dev-python/pypdf
parent4d190a87291ace8503ad92c6b049d14660a14c72 (diff)
gentoo auto-resync : 08:04:2024 - 06:31:00
Diffstat (limited to 'dev-python/pypdf')
-rw-r--r--dev-python/pypdf/Manifest2
-rw-r--r--dev-python/pypdf/pypdf-4.2.0.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/pypdf/Manifest b/dev-python/pypdf/Manifest
index d9bd8d74dd0e..6da6a7f647c8 100644
--- a/dev-python/pypdf/Manifest
+++ b/dev-python/pypdf/Manifest
@@ -1,4 +1,6 @@
DIST pypdf-4.1.0.gh.tar.gz 8005929 BLAKE2B 3bec62a86dc8503a8738ea14941db6f66181784288d51f345f6d0a973e80c984c676814820ee68d7d5372931272747a22def10928f935ea7bdef2f2a5cdffd28 SHA512 1dac8f45d24406b17a6c0872fdac928b2aa8e434d64b5f8bd3359ca58f51e7a936d0990d3a7d4b4bbd433ca1497e343838ab0dbd3d22f2db32575472f1a660c9
+DIST pypdf-4.2.0.gh.tar.gz 8009612 BLAKE2B a21108679a6dd5d9bc16aaf4a9c1beaaab875f0a8f974722d6d318635eecee82bc37c7c4c175816079ce9604f8b88f07f31458b08994833a25ee18bc46cbc294 SHA512 99fe599a81ae7e115ee6fca82ffabaff613ee49756a7e937de32a4d59b5731effe5cc3a076d92423b2299896a6ecab41ab5096aea6836fec79ba637e2c7b7620
DIST pypdf-sample-files-8c405ece5eff12396a34a1fae3276132002e1753.gh.tar.gz 11748093 BLAKE2B c5989200893b28a3c2062bb024a5cfc6f3389dc259ec129857979fa43469e1274559612b4d555499e2c7e16cf34be07825229932bf4d147fa6d7324d043e97d5 SHA512 c9771129b7668a2fd1fa79bb859ae9213f3d60341cf1b9937ff0eaab0de9bf4c35adcb7b896e93329038dc0f3809a0c697c523f8fe41b43030b0b029a88058e3
EBUILD pypdf-4.1.0.ebuild 1513 BLAKE2B a6cf4d675fff86a4238c520a76f2cd26b4d4000b506b362de6e841b8c825d89e6f8ff4c28507c363fdc51ed1559d795d545e7be5e2d4c286ece864c62f6bbf28 SHA512 11ddfc05752938ffe1ca9ec1588899aae81cb3bb46d8d69523a3cc2cc00777dbacf61199ff2342b8d95f414e0d03ad230a7865f6f6b14596a822b4d0906d7e11
+EBUILD pypdf-4.2.0.ebuild 1617 BLAKE2B 8f0351a4e20ea96c04ab17d19f6c147135dd9f7ba3f0b84e77ee526bc07c5dd0f3b675778992218046394cc7abcd2eb54ce672615996452b8bc42409e1b5b092 SHA512 eaa143cbf69b6b2a541bba81de473fc20bde7c89a550f7eb6b01d841e63c2a365f75996e0e0b632ddb1e33cbc109cfaa3dbb5588564fbb2c78669732e7584fed
MISC metadata.xml 373 BLAKE2B a829b7048eb3a95caeb1be83b6172603df6a031d40995294f2687bf3c3cb70e66fafb9ba8339d9979fc85f5936b9552963a8fcd072a20661fa78f3aa3c4b89c0 SHA512 775ac2de487f11fba1ea8d283b42b9ef56e42cd95ea11f50a06b099420e69c0567f65c506b14891ac641da90ea05ca70da4f8a3e4a028cf41bdbc823021dccfe
diff --git a/dev-python/pypdf/pypdf-4.2.0.ebuild b/dev-python/pypdf/pypdf-4.2.0.ebuild
new file mode 100644
index 000000000000..50fccfce8014
--- /dev/null
+++ b/dev-python/pypdf/pypdf-4.2.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+SAMPLE_COMMIT=8c405ece5eff12396a34a1fae3276132002e1753
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/pypdf/
+ https://github.com/py-pdf/pypdf/
+"
+SRC_URI="
+ https://github.com/py-pdf/pypdf/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
+ -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
+ )
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.0.0[jpeg,jpeg2k,tiff,zlib,${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_unpack() {
+ default
+ if use test; then
+ mv "sample-files-${SAMPLE_COMMIT}"/* "${S}"/sample-files/ || die
+ fi
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/test_reader.py::test_decode_permissions
+ tests/test_workflows.py::test_text_extraction_layout_mode
+ # rely on -Werror
+ tests/test_utils.py::test_deprecate_no_replacement
+ tests/test_workflows.py::test_orientations
+ tests/test_writer.py::test_remove_image_per_type
+ tests/test_generic.py::test_name_object
+ # Internet
+ tests/test_generic.py::test_calling_indirect_objects
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -m "not enable_socket"
+}