summaryrefslogtreecommitdiff
path: root/dev-python/pypax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/pypax
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pypax')
-rw-r--r--dev-python/pypax/Manifest4
-rw-r--r--dev-python/pypax/metadata.xml20
-rw-r--r--dev-python/pypax/pypax-0.9.2.ebuild48
-rw-r--r--dev-python/pypax/pypax-9999.ebuild48
4 files changed, 0 insertions, 120 deletions
diff --git a/dev-python/pypax/Manifest b/dev-python/pypax/Manifest
deleted file mode 100644
index 336c65de5508..000000000000
--- a/dev-python/pypax/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST elfix-0.9.2.tar.gz 398758 BLAKE2B 22f8d9e85be2ae9bd906dfa6a1d8b7614f017686b4563ef7e97898a112a56cff59a8cb906ec957b7a111a5c9251a3de6b13dfb66ef9f732099ac610928d5321e SHA512 a7be30722abe7249ec42024d33b2bda00524cfb85da66b4511c5056efbdbfae1d3c2b42048bcf4d5cb7c0ae675f763b74a834d93a25b541ebac42fddcd2c6cf9
-EBUILD pypax-0.9.2.ebuild 1096 BLAKE2B 3f378b21f4904575718268ee1336a5e269d48271c56a8cf3fae220ef53f7cc4231f0cdec6d6de3843637c91bc5e2a2de70d0653cd932ed768dadde43743bbef1 SHA512 487e76b4882e97c3417be3262b85f962c1dbb98ca69bc16bc834dd8385b6c5d387fc3c8ef4f12eef6387559ddd340f05b2bc7ba736f9a8dc98621ec0e475b29b
-EBUILD pypax-9999.ebuild 1105 BLAKE2B 753a9202476893a19f00da53816499a9912e5bce24fad99f02bd89edafcc0df241b5f1836aa5aff3005194a74d99782df099facbc0717f6839219bfdbb5ba49f SHA512 08070f4304df5b8b1e90b4d95c3a9870e084cb88488d39ebe58aaff725ccf7ac5c1d8914803a44a8386a3fab1008138ab1a8bfab9f2e519360a54a4c388b5881
-MISC metadata.xml 597 BLAKE2B e154315aac17c35f33adc8dd7e33a6427029a34629979d2a7cfa6f373a56a9dbb6add22bfb359ba4126a29b172557393b96cea123224551d88894e5c5f637bbf SHA512 d5820da1b741114d7ecaf7cb7f0b6f1c08d675e53992c8fbf87f562c3b949ff7336e093a3a502202e671be299310c14a2a38b8d54d3485e0d9064964eb1ed87b
diff --git a/dev-python/pypax/metadata.xml b/dev-python/pypax/metadata.xml
deleted file mode 100644
index caddff84b5bc..000000000000
--- a/dev-python/pypax/metadata.xml
+++ /dev/null
@@ -1,20 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>blueness@gentoo.org</email>
- <name>Anthony G. Basile</name>
- </maintainer>
- <maintainer type="project">
- <email>hardened@gentoo.org</email>
- <name>Gentoo Hardened</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <use>
- <flag name="xtpax">Enable XATTR_PAX_FLAGS support.</flag>
- <flag name="ptpax">Enable PT_PAX_FLAGS support.</flag>
- </use>
-</pkgmetadata>
diff --git a/dev-python/pypax/pypax-0.9.2.ebuild b/dev-python/pypax/pypax-0.9.2.ebuild
deleted file mode 100644
index 322214eba633..000000000000
--- a/dev-python/pypax/pypax-0.9.2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
-
-inherit distutils-r1
-
-if [[ ${PV} == *9999* ]] ; then
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/elfix.git"
- inherit git-r3
-else
- SRC_URI="https://dev.gentoo.org/~blueness/elfix/elfix-${PV}.tar.gz"
- KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86"
- S="${WORKDIR}/elfix-${PV}"
-fi
-
-DESCRIPTION="Python module to get or set either PT_PAX and/or XATTR_PAX flags"
-HOMEPAGE="https://dev.gentoo.org/~blueness/elfix/
- https://www.gentoo.org/proj/en/hardened/pax-quickstart.xml"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="+ptpax +xtpax"
-
-REQUIRED_USE="|| ( ptpax xtpax )"
-
-RDEPEND="
- ptpax? ( dev-libs/elfutils )
- xtpax? ( sys-apps/attr )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${RDEPEND}"
-
-src_compile() {
- cd scripts || die
- unset PTPAX
- unset XTPAX
- use ptpax && export PTPAX="yes"
- use xtpax && export XTPAX="yes"
- distutils-r1_src_compile
-}
-
-src_install() {
- cd scripts || die
- distutils-r1_src_install
-}
diff --git a/dev-python/pypax/pypax-9999.ebuild b/dev-python/pypax/pypax-9999.ebuild
deleted file mode 100644
index 39846769a8c1..000000000000
--- a/dev-python/pypax/pypax-9999.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
-
-inherit distutils-r1
-
-if [[ ${PV} == *9999* ]] ; then
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/elfix.git"
- inherit git-r3
-else
- SRC_URI="https://dev.gentoo.org/~blueness/elfix/elfix-${PV}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
- S="${WORKDIR}/elfix-${PV}"
-fi
-
-DESCRIPTION="Python module to get or set either PT_PAX and/or XATTR_PAX flags"
-HOMEPAGE="https://dev.gentoo.org/~blueness/elfix/
- https://www.gentoo.org/proj/en/hardened/pax-quickstart.xml"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="+ptpax +xtpax"
-
-REQUIRED_USE="|| ( ptpax xtpax )"
-
-RDEPEND="
- ptpax? ( dev-libs/elfutils )
- xtpax? ( sys-apps/attr )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${RDEPEND}"
-
-src_compile() {
- cd scripts || die
- unset PTPAX
- unset XTPAX
- use ptpax && export PTPAX="yes"
- use xtpax && export XTPAX="yes"
- distutils-r1_src_compile
-}
-
-src_install() {
- cd scripts || die
- distutils-r1_src_install
-}