summaryrefslogtreecommitdiff
path: root/dev-python/pyparted/pyparted-3.12.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/pyparted/pyparted-3.12.0.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/pyparted/pyparted-3.12.0.ebuild')
-rw-r--r--dev-python/pyparted/pyparted-3.12.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyparted/pyparted-3.12.0.ebuild b/dev-python/pyparted/pyparted-3.12.0.ebuild
new file mode 100644
index 000000000000..2496d9e96f86
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.12.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for sys-block/parted"
+HOMEPAGE="https://github.com/dcantrell/pyparted/"
+SRC_URI="https://github.com/dcantrell/pyparted/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ >=sys-block/parted-3.4
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? ( dev-python/six[${PYTHON_USEDEP}] )
+ virtual/pkgconfig
+"
+
+distutils_enable_tests unittest