summaryrefslogtreecommitdiff
path: root/dev-python/pyparted/pyparted-3.11.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/pyparted/pyparted-3.11.7.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/pyparted/pyparted-3.11.7.ebuild')
-rw-r--r--dev-python/pyparted/pyparted-3.11.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyparted/pyparted-3.11.7.ebuild b/dev-python/pyparted/pyparted-3.11.7.ebuild
new file mode 100644
index 000000000000..5535859ce228
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.11.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for sys-block/parted"
+HOMEPAGE="https://github.com/dcantrell/pyparted/"
+SRC_URI="https://github.com/dcantrell/pyparted/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ >=sys-block/parted-3.2
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/decorator[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( dev-python/six[${PYTHON_USEDEP}] )
+ virtual/pkgconfig
+"
+
+distutils_enable_tests unittest