summaryrefslogtreecommitdiff
path: root/dev-python/pyparted/pyparted-3.10.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyparted/pyparted-3.10.7.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyparted/pyparted-3.10.7.ebuild')
-rw-r--r--dev-python/pyparted/pyparted-3.10.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pyparted/pyparted-3.10.7.ebuild b/dev-python/pyparted/pyparted-3.10.7.ebuild
new file mode 100644
index 000000000000..86c712c92e3f
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.10.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for sys-block/parted"
+HOMEPAGE="https://github.com/rhinstaller/pyparted/"
+SRC_URI="${HOMEPAGE}archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="test"
+REQUIRED_USE="
+ test? ( python_targets_python2_7 )
+"
+
+RDEPEND="
+ >=sys-block/parted-3.1
+ dev-python/decorator[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.10.3-greater.patch
+)
+
+python_test() {
+ emake test
+}