summaryrefslogtreecommitdiff
path: root/dev-python/pyparsing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-26 12:00:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-26 12:00:09 +0100
commitf300354de9fe5d997850456a9e1f400193e6544f (patch)
tree402fd6a7727db790bf57f683894052e8791d389e /dev-python/pyparsing
parent5c42677148c717eb9f4673237db807f74740b4e9 (diff)
gentoo auto-resync : 26:08:2024 - 12:00:09
Diffstat (limited to 'dev-python/pyparsing')
-rw-r--r--dev-python/pyparsing/Manifest2
-rw-r--r--dev-python/pyparsing/pyparsing-3.1.4.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pyparsing/Manifest b/dev-python/pyparsing/Manifest
index 096dd26a5b34..0db3bb525854 100644
--- a/dev-python/pyparsing/Manifest
+++ b/dev-python/pyparsing/Manifest
@@ -1,3 +1,5 @@
DIST pyparsing-3.1.2.tar.gz 889571 BLAKE2B 69dc249c8760470e9611c367255176afcbfdf299b739c8e191f71b88653e0d35db3a20d156ae6507a1748f775b0853c127986d9de2124edc12e22453a75b908d SHA512 1134949f3576edbec4438eefe952eb5cc6e734fb060905d714b6a77f71e90d364b01345df5e7b8fb5ffa798c530be9c65f6d152b3f591cba787660c4dd8894d2
+DIST pyparsing-3.1.4.tar.gz 900231 BLAKE2B 121092316528a69f79a8fac5e903de513c4193bd00d5ef7e98dfcb09f3a48eb3384217ede39b0f954f58bdade8644931ce8cef41729539fc1be3dfb910b90be7 SHA512 b475e5571510cd7b07fecbc8ae583b1e75a6308b64018d2884570dfa461e0529b96d02d11403cecac41f92b5d802a5dd4bbf9f8321d58ffa2d24cb89b86652e1
EBUILD pyparsing-3.1.2.ebuild 1562 BLAKE2B cec3bd45a2f87481428c184a4206b4477dc20a4b70db066fd2547ef06620529cad18ffeab7b26fb6dfec1421464b1b38bc1805a47f5200975836d40676ce70a0 SHA512 a74a673bd32270fdd59fba972609fbf083c7b167ada04fa45714274f8044ae43b8e7553eb957931d5d7d2c1c3256b38610407c4a222c52d1fe344bc9b6237c33
+EBUILD pyparsing-3.1.4.ebuild 1570 BLAKE2B 0a8f99f8f0d5bafac7878372d3849650776c2da2eb717e275cb5816dbbb94ec2303f16e0ad1270e8915c9d2dd755ac9285697d796c55ce79cd8ae5562f9645d7 SHA512 22121e601effa2890e655958b2f93e81a6771e7e721b2e9df9ef8aabbfac2bb575f084354dce9ca5bdd21836aa0995d8e6e84944316581f4a04daa5ddc9748f9
MISC metadata.xml 797 BLAKE2B 9707adcde7106fb0726de82da965fc3aaf7a23b34f4b71cfea4e09bd03cb44c069ccd4d16e6a6f37eca4720ff8c52d0bc11c864bd7dd9e6995d0d25cb92c5cc2 SHA512 0f791598d2b4a37797e7f917be22093f01020cde34876d7d0db3d1b2bf5da8a18d5399d70f381d98ea569f8c3abf7f1cff8b3cc92fbab39bb00f329a58e96229
diff --git a/dev-python/pyparsing/pyparsing-3.1.4.ebuild b/dev-python/pyparsing/pyparsing-3.1.4.ebuild
new file mode 100644
index 000000000000..f97642f139e3
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-3.1.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2004-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easy-to-use Python module for text parsing"
+HOMEPAGE="
+ https://github.com/pyparsing/pyparsing/
+ https://pypi.org/project/pyparsing/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="examples"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # railroad-diagrams not packaged (and not suitable for packaging yet)
+ tests/test_diagram.py
+)
+
+EPYTEST_DESELECT=(
+ # also railroad-diagrams
+ tests/test_examples.py::TestExamples::test_range_check
+ tests/test_unit.py::Test02_WithoutPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test04_WithPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test06_WithBoundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test08_WithUnboundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test09_WithLeftRecursionParsing::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test10_WithLeftRecursionParsingBoundedMemo::testEmptyExpressionsAreHandledProperly
+)
+
+python_install_all() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}