summaryrefslogtreecommitdiff
path: root/dev-python/pyparsing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-19 07:50:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-19 07:50:17 +0100
commit262a170a603cee433f640577f13472ab41a5d3aa (patch)
treec8cd6d9417b8a1f2275883279d2ceaedba7207f3 /dev-python/pyparsing
parent37cd441738bc6681ca075c01b6dd06056a27abbf (diff)
gentoo auto-resync : 19:06:2023 - 07:50:17
Diffstat (limited to 'dev-python/pyparsing')
-rw-r--r--dev-python/pyparsing/Manifest2
-rw-r--r--dev-python/pyparsing/pyparsing-3.1.0.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pyparsing/Manifest b/dev-python/pyparsing/Manifest
index af235b7d9b69..89d7129dcdd7 100644
--- a/dev-python/pyparsing/Manifest
+++ b/dev-python/pyparsing/Manifest
@@ -1,3 +1,5 @@
+DIST pyparsing-3.1.0.tar.gz 882565 BLAKE2B 8ed2e15e2422ded9a558b866a5cbbdc0fb6c7ce42962710e42cfd751aae7b48bacd3d6201084189a940d262fb7b142ea37b897bae23f97a175f6152c19adb5c9 SHA512 0ad2e8fff93708426b3675e2d41da12b3f09531bf272799db4095ee618bbaa0f4b90e527ff09dda2acbdb923d59117678fbb28b82a7cfd2b395d686f47b61850
DIST pyparsing_3.0.9.gh.tar.gz 967771 BLAKE2B c13c74661b9e0d53b4886c9949b01951d220991f916362a13ce0c32c0ab05a6b1cab4d5e5a626acb7563c0ec1716348ede205cb67bf22c0710904f07404ad82a SHA512 1158f27e31f8eced540217b7234b09005eac416fad74faf59678fdae93fe2f76e0e3b5f4adfd3ceb42c8aef19150950293e989c9a5189741175073eb7a03cd6d
EBUILD pyparsing-3.0.9.ebuild 1642 BLAKE2B 95b4ff0514e48edaf573339019df5c42ea04b88cf0fc99e12ed2a7cf631b71c22dd5bd8906b7f586487be29a3e512b94317d69f7c80157aa48f12d76cf225982 SHA512 8c6d90b8804c856dfe2e05d3b59399296098374f7c9289bcc0d1e784e8e79d8b698d1199b3fe786615bde17116b0ed3403f1e7577fc0e08c6f30e8d767f3933e
+EBUILD pyparsing-3.1.0.ebuild 1570 BLAKE2B 3de5123b9c263683514e49f91324fd40c8dddca3f68c0f9838fe9861162c46e3cb7f8609119df6076b51c6bf78a3c04bc4d9f2cc24bfe6eee97c45890e509fe5 SHA512 ecab3cb67d45b5599886e2a00fa7eb40ba16544c2c85e34130f137d1068efcc75c1aa8e7faa54ca2fd1fe5ed5ebd3d3852db9615359d0e662bc999f8da6cf8d4
MISC metadata.xml 797 BLAKE2B 9707adcde7106fb0726de82da965fc3aaf7a23b34f4b71cfea4e09bd03cb44c069ccd4d16e6a6f37eca4720ff8c52d0bc11c864bd7dd9e6995d0d25cb92c5cc2 SHA512 0f791598d2b4a37797e7f917be22093f01020cde34876d7d0db3d1b2bf5da8a18d5399d70f381d98ea569f8c3abf7f1cff8b3cc92fbab39bb00f329a58e96229
diff --git a/dev-python/pyparsing/pyparsing-3.1.0.ebuild b/dev-python/pyparsing/pyparsing-3.1.0.ebuild
new file mode 100644
index 000000000000..5a9966efcc40
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-3.1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2004-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easy-to-use Python module for text parsing"
+HOMEPAGE="
+ https://github.com/pyparsing/pyparsing/
+ https://pypi.org/project/pyparsing/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="examples"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # railroad-diagrams not packaged (and not suitable for packaging yet)
+ tests/test_diagram.py
+)
+
+EPYTEST_DESELECT=(
+ # also railroad-diagrams
+ tests/test_examples.py::TestExamples::test_range_check
+ tests/test_unit.py::Test02_WithoutPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test04_WithPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test06_WithBoundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test08_WithUnboundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test09_WithLeftRecursionParsing::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test10_WithLeftRecursionParsingBoundedMemo::testEmptyExpressionsAreHandledProperly
+)
+
+python_install_all() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}