summaryrefslogtreecommitdiff
path: root/dev-python/pyparsing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-python/pyparsing
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-python/pyparsing')
-rw-r--r--dev-python/pyparsing/Manifest2
-rw-r--r--dev-python/pyparsing/pyparsing-3.0.8.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pyparsing/Manifest b/dev-python/pyparsing/Manifest
index 67f35280f38d..6c7dac421cff 100644
--- a/dev-python/pyparsing/Manifest
+++ b/dev-python/pyparsing/Manifest
@@ -1,3 +1,5 @@
DIST pyparsing_3.0.7.tar.gz 944917 BLAKE2B bcbcd18817c69a69ac6863affb1309a5ca63fe46a45dc056d8407d79a77d1f19e4d1abce08f5d6f1aff7cbdaefb5b699787abcddfcbf64e5514e79e2b0b86ce6 SHA512 d5d5547188ebda6fb7f45928174314d3d4d10302acc8fb476cd6590fb4a75167dee5f6397ab0b63efd4cb55c0765708ffd432bcfecf28d8f808815e62615f447
+DIST pyparsing_3.0.8.tar.gz 948516 BLAKE2B 8df61ce3c5f0b9ef725bf750fa25c26e482a5786b6c3a03befbf7945c76f67981d0f60bfc98badeb353274e5e3c8442e105ae635d0b93681e23090e70716ce0a SHA512 5567824ac6d4c17755c0d47f2994cc2449383d9d3e9dfa374886d92af38651334483034713df420701d1c4560b331f61d763f7f8d1d7a14a7d221c022b9fc8a7
EBUILD pyparsing-3.0.7-r1.ebuild 2002 BLAKE2B 4385eb13eafb4fc84b4151f0e96a87ad44dd465a651bad98db559b50f45192be9816e1b658f5989181d6ab5c04b76e76c08ca7233260cbed39e3f4bf08af896e SHA512 bfbaf2e219c8bddab5b4fcd6ff022d46cf81feadeae5d684be39f512f85619a98d1760fe90b5ce8aca2f3fac41c45a5545b2fa9d00aad5a990eb3434cb39f3e2
+EBUILD pyparsing-3.0.8.ebuild 1647 BLAKE2B af24982538b0bd81e15da4e6e3332a7932cc748e10cebd5eda54d4c921c64825bf9376a9089ee40dc403a5fe9b4f973a4acf95a2e81507908c3fd80fc3375dd0 SHA512 add66bbd01165f13a4c1c9c7e0a3b5ec4be3e465103adeb28851bb180003a89ea977c30abafd49996121c4285f517037c25f49d3a7930d150b0dd9cab5b0de7a
MISC metadata.xml 797 BLAKE2B 9707adcde7106fb0726de82da965fc3aaf7a23b34f4b71cfea4e09bd03cb44c069ccd4d16e6a6f37eca4720ff8c52d0bc11c864bd7dd9e6995d0d25cb92c5cc2 SHA512 0f791598d2b4a37797e7f917be22093f01020cde34876d7d0db3d1b2bf5da8a18d5399d70f381d98ea569f8c3abf7f1cff8b3cc92fbab39bb00f329a58e96229
diff --git a/dev-python/pyparsing/pyparsing-3.0.8.ebuild b/dev-python/pyparsing/pyparsing-3.0.8.ebuild
new file mode 100644
index 000000000000..0c8cb9eb70bc
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-3.0.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2004-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/_}
+DESCRIPTION="Easy-to-use Python module for text parsing"
+HOMEPAGE="https://github.com/pyparsing/pyparsing https://pypi.org/project/pyparsing/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # railroad-diagrams not packaged (and not suitable for packaging yet)
+ tests/test_diagram.py
+)
+
+EPYTEST_DESELECT=(
+ # also railroad-diagrams
+ tests/test_unit.py::Test02_WithoutPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test04_WithPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test06_WithBoundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test08_WithUnboundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test09_WithLeftRecursionParsing::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test10_WithLeftRecursionParsingBoundedMemo::testEmptyExpressionsAreHandledProperly
+)
+
+python_install_all() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}