summaryrefslogtreecommitdiff
path: root/dev-python/pypam
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/pypam
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/pypam')
-rw-r--r--dev-python/pypam/Manifest1
-rw-r--r--dev-python/pypam/pypam-0.5.0-r5.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pypam/Manifest b/dev-python/pypam/Manifest
index 4a91631a637a..949b6c7e3829 100644
--- a/dev-python/pypam/Manifest
+++ b/dev-python/pypam/Manifest
@@ -6,4 +6,5 @@ AUX PyPAM-python3-support.patch 5987 BLAKE2B 3c3723c0c3c121d6341aae48b1b8a47c2ed
AUX pypam-0.5.0-stricter.patch 335 BLAKE2B ac348ae8ae8db84a5e5b92c3dc842bc843e28af23c34e929b63fbe029f70233689efd6974a65e3dce48f0ce28ec4195698566268972f895106d96d796647116c SHA512 6cb56d4610fab8f14af83d64215de24b38c820c61099054c0c02bcc831b0f50dee5746def85e2ae669b8657dce2fe31fcc93f07a93e3b49f0c7a78f48acd74c7
DIST PyPAM-0.5.0.tar.gz 105206 BLAKE2B 7778275cae11606ca8e522d2f99fb0558c55545cdaedb3ff7c55b4bb693ed3429e22566912f53c7795f73316bc45f1bfbdf5a53daec234dba87e1c141e2410f2 SHA512 9e0e919e34930d2283307cd6665c5287c664a76a5de56367bd975867ac26b376ae03d30cb3bc4a16390c977ca2690cfd2e90ac73dcc7886b8c999444da4a07e0
EBUILD pypam-0.5.0-r4.ebuild 1036 BLAKE2B 9c4ab6d52d6d3cb75462a2db2560fc5ef8315dec6b9d83fe9221ae6aa3797ce4cb2b3e3bae71903bcb48411d8e7b52c7b1d8ad0b1e17c8669566f0f1a9d74a99 SHA512 dd09e672f343152ec527f019abb7d16ccd28514c627e7638ba79db5dd8c3983a983d5deb864b424d07bd1433f3b0b7235e5dae16dfeb882fbe30536dd6efdb4e
+EBUILD pypam-0.5.0-r5.ebuild 1037 BLAKE2B 3a8daa16065ae83d783f688e52854f625ab5d39357b2572996572e1c9987691b4d0291c72befebd3fc69007b978d0a855fe353b822a5141ea281aef6155f5f96 SHA512 f67d881c21cef40d3929206aebee0d6fd0b68f566b1f8e4f0a3cb7ee9aa9da6ffa2d70092065e994203aa7bf63dd831bac93ac6f03f0b43c133226cca5912e40
MISC metadata.xml 165 BLAKE2B ed7e2ebe9f71491aa6163627bdb6606e798b98ca85c053b50442182a245074a9e09b290835e7c8fb4a10e4e8227c16ec306fd16f337cb66904095d864e698e8b SHA512 bebe508b4e0a7ca4a046f9befd3d7ddb702756024756a5f0d9fb5ace5fe3f5a98f9d42afda4597b7d1338607b8d43e41c8fcd6d20d31da3ebad2b420edd2cb59
diff --git a/dev-python/pypam/pypam-0.5.0-r5.ebuild b/dev-python/pypam/pypam-0.5.0-r5.ebuild
new file mode 100644
index 000000000000..d2e07613cfd6
--- /dev/null
+++ b/dev-python/pypam/pypam-0.5.0-r5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{6..9} )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN="PyPAM"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python Bindings for PAM (Pluggable Authentication Modules)"
+HOMEPAGE="http://www.pangalactic.org/PyPAM"
+SRC_URI="http://www.pangalactic.org/PyPAM/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/pam-0.64"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS examples/pamtest.py )
+
+PATCHES=(
+ # Pull patches from fedora.
+ "${FILESDIR}/PyPAM-${PV}-dealloc.patch"
+ "${FILESDIR}/PyPAM-${PV}-nofree.patch"
+ "${FILESDIR}/PyPAM-${PV}-memory-errors.patch"
+ "${FILESDIR}/PyPAM-${PV}-return-value.patch"
+ "${FILESDIR}/PyPAM-python3-support.patch"
+ # Fix a missing include.
+ "${FILESDIR}/${P}-stricter.patch"
+)
+
+src_compile() {
+ append-cflags -fno-strict-aliasing
+ distutils-r1_src_compile
+}
+
+python_test() {
+ "${PYTHON}" tests/PamTest.py
+}