summaryrefslogtreecommitdiff
path: root/dev-python/pyotp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /dev-python/pyotp
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'dev-python/pyotp')
-rw-r--r--dev-python/pyotp/Manifest1
-rw-r--r--dev-python/pyotp/pyotp-2.2.6-r1.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pyotp/Manifest b/dev-python/pyotp/Manifest
index 682562b0d908..3c244b35a995 100644
--- a/dev-python/pyotp/Manifest
+++ b/dev-python/pyotp/Manifest
@@ -1,3 +1,4 @@
DIST pyotp-2.2.6.tar.gz 10602 BLAKE2B 801f48646ff15a039b9295948ed292c3c432f8b0b629d249554259802335b7430a2c82f8c3bee1f54df71b0972ec293d69a2005c35cac120a51cec1a3548b2c1 SHA512 4f962704411ceebff967cf13af5ec5b815da0f82af665a086c4e5d53acc735453d638c65aa2afa40fe546e92d04a9250f6964cb22270a67c9609f8486eb5ba90
+EBUILD pyotp-2.2.6-r1.ebuild 594 BLAKE2B 918cbd0dbebe3c5bacdd11ca648efcfd84a9c720857b8ace39320d0256c9d3d8ef1a1047629b8374e062649c9cb90e954ae64717013dd1ed2c8b481c6f2a6447 SHA512 f87721a3a935268667bb09682bd3eb18a3e4ac3b1d2336fe41f7fcc532a5e16a9208d679889f5d20a0506fd1c168e0ef714ce7c20a379d59b71635e5e202ae61
EBUILD pyotp-2.2.6.ebuild 592 BLAKE2B 7111307b8582cf202b0fc7bad95c5a448b62564e4260438141d9234ca3d34d3207d77a71e2e305c5d60c467a0b6bffa6a66d3d3795e4832ffb5dc439cb64953e SHA512 da6df95db63d10f6cb1b92101680f6092093520421ee75f12b3325900dd7b851b1d1a26e9a5e1fad1c9ae6e055b9ebbe2f954b3412b232a0e7faa67143a845dd
MISC metadata.xml 381 BLAKE2B 0ce0f75aab60659850e7d04532911feea89a4bccf8ec7826ebfb924416af438d5a2bf7981435a22e825b39881ac20a8b2a0bd93a66b2d7b031c72123033f1d78 SHA512 9b3a37c75a62f1873288ffba45ab105225a90d72e01c7ead253b5a903ec28babe152074cc7595d6398104f8ccc50ebfc71ff72c4e620a7dad1b5e57f767cd118
diff --git a/dev-python/pyotp/pyotp-2.2.6-r1.ebuild b/dev-python/pyotp/pyotp-2.2.6-r1.ebuild
new file mode 100644
index 000000000000..cd97f5e226f7
--- /dev/null
+++ b/dev-python/pyotp/pyotp-2.2.6-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="PyOTP is a Python library for generating and verifying one-time passwords."
+HOMEPAGE="https://github.com/pyotp/pyotp https://pypi.org/project/pyotp/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Testing failed with ${EPYTHON}"
+}