summaryrefslogtreecommitdiff
path: root/dev-python/pyotherside
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-28 19:27:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-28 19:27:52 +0000
commit4b1be5ef874aaeb61a2116048e0c2312e53f8c69 (patch)
treee2f0118b102bf7e7ad852582d410adb43f13b035 /dev-python/pyotherside
parent4418da21bd05d610a3450f4aa75481785ca372a0 (diff)
gentoo auto-resync : 28:02:2025 - 19:27:52
Diffstat (limited to 'dev-python/pyotherside')
-rw-r--r--dev-python/pyotherside/Manifest2
-rw-r--r--dev-python/pyotherside/pyotherside-1.6.1.ebuild103
2 files changed, 0 insertions, 105 deletions
diff --git a/dev-python/pyotherside/Manifest b/dev-python/pyotherside/Manifest
index a08317b4db6b..7131ce7fe882 100644
--- a/dev-python/pyotherside/Manifest
+++ b/dev-python/pyotherside/Manifest
@@ -1,5 +1,3 @@
-DIST pyotherside-1.6.1.tar.gz 184539 BLAKE2B 32c017b6d3a64a3125f779a0201ee15288fbcc84bf070442dc542df525f5994cee6b334d86ff2bbbcada39f645ac2e900a459d729c4f8c838d529fb33bdf1226 SHA512 ea672405b97d09b3c4f1266b1714da5e127c47f8f1c99caa282bd823261c06a0b02e7094185724863f339a0bd35d45426bdf6e8cb7d37a8a23d1d18e81939d9d
DIST pyotherside-1.6.2.tar.gz 184620 BLAKE2B 78e02274f71a30c6bc0d78eb993d070e7dfc9487c3964ceb4138338180b00e837006de6c15adb6168c52dab87959961e2b2cf40cce5eb123e01aaaf06fc03cad SHA512 5f625b733bf9b15b16236be836696d62c9297bafcbb491dc2ec353522612c1b593379c130e281b7b259acdbffb5cd89fb46e060969d29e7ed2d1452c6bbf43d2
-EBUILD pyotherside-1.6.1.ebuild 1749 BLAKE2B 6b844b904b25ae43a746d52f028e0cdd060bf3629d7020c6aec5333aea1b25d02d1114270ff1906ab8249b57551bbf5d246f0280a237dbbb6bdb77a00f49fa79 SHA512 c2a27abaaf614c8c126f517f94fa6d6d970c3a3cec99b7c6dff1761353df014b0454484a3ea5ab9e1e77a7dad1d79225b5f64fd7ee8fdd18a97197e668f1bc80
EBUILD pyotherside-1.6.2.ebuild 1750 BLAKE2B e093aec3ebaeb40001faa9186e2d82a49016faa9b247ce0735894e4adeb48ced97640a7670f85154b40f569795c29ef97dd074fc5434482c1272a23a5dd310a7 SHA512 fa9b563aed7ba5e83cd0d9a72e9844a26072bed12f313b4405e1d6a92c84ba9edbe9f3c222183b8b548696f37f51d2809076cb281228fd5cb90ccf302b6d1ab9
MISC metadata.xml 321 BLAKE2B 713f2fd8fc80ffbe8c3fe517da4e2f6633f0a95f279ae1b0f8448aa3fcb0ef04ffc3f56fb42e3060dee09604de58efed48c5ac0caa12ed37d59c87f68bc60492 SHA512 f86cf33a5affa455d35fa26da3eaab0864eb35563aa50287f7276fae9a3b36c46292eed016200bba1dcf407cd5eef7f2da7c57d765a7d6df4850a1dfeb243fe1
diff --git a/dev-python/pyotherside/pyotherside-1.6.1.ebuild b/dev-python/pyotherside/pyotherside-1.6.1.ebuild
deleted file mode 100644
index 366d71378ae4..000000000000
--- a/dev-python/pyotherside/pyotherside-1.6.1.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit multibuild qmake-utils python-single-r1
-
-DESCRIPTION="Asynchronous Python 3 Bindings for Qt"
-HOMEPAGE="
- https://github.com/thp/pyotherside/
- https://thp.io/2011/pyotherside/
-"
-SRC_URI="
- https://github.com/thp/pyotherside/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
-IUSE="qt5 qt6"
-
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
- || ( qt5 qt6 )
-"
-
-DEPEND="
- ${PYTHON_DEPS}
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtdeclarative:5
- dev-qt/qtgui:5
- dev-qt/qtopengl:5
- dev-qt/qtsvg:5
- )
- qt6? (
- dev-qt/qtbase:6[opengl]
- dev-qt/qtdeclarative:6[opengl]
- dev-qt/qtquick3d:6[opengl]
- dev-qt/qtsvg:6
- )"
-RDEPEND="
- ${DEPEND}
-"
-
-pkg_setup() {
- MULTIBUILD_VARIANTS=( $(usev qt5) $(usev qt6) )
- python_setup
-}
-
-src_prepare() {
- default
- sed -i -e "s/qtquicktests//" pyotherside.pro || die
- multibuild_copy_sources
-}
-
-src_configure() {
- myconfigure() {
- pushd "${BUILD_DIR}" > /dev/null || die
-
- case ${MULTIBUILD_VARIANT} in
- qt5)
- eqmake5
- ;;
- qt6)
- eqmake6
- ;;
- *)
- # This should never happen if REQUIRED_USE is enforced
- die "Neither Qt5 nor Qt6 support enabled, aborting"
- ;;
- esac
-
- popd > /dev/null || die
- }
-
- multibuild_foreach_variant myconfigure
-}
-
-src_compile() {
- mycompile() {
- emake -C "${BUILD_DIR}"
- }
-
- multibuild_foreach_variant mycompile
-}
-
-src_test() {
- mytest() {
- QT_QPA_PLATFORM="offscreen" "${BUILD_DIR}"/tests/tests || die
- }
-
- multibuild_foreach_variant mytest
-}
-
-src_install() {
- myinstall() {
- emake -C "${BUILD_DIR}" install INSTALL_ROOT="${D}"
- }
-
- multibuild_foreach_variant myinstall
-}