summaryrefslogtreecommitdiff
path: root/dev-python/pyotherside
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-28 13:37:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-28 13:37:56 +0100
commit1919539ec916b166ea3a7b6c5778c40d5bccad70 (patch)
tree8d03694e000aa8e1d2f84456dadbad899b3dbbd6 /dev-python/pyotherside
parent1a39e197a344b8ec7e3ed6c173bdf2a1ccba5b6b (diff)
gentoo auto-resync : 28:06:2023 - 13:37:56
Diffstat (limited to 'dev-python/pyotherside')
-rw-r--r--dev-python/pyotherside/Manifest2
-rw-r--r--dev-python/pyotherside/pyotherside-1.6.0.ebuild7
2 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/pyotherside/Manifest b/dev-python/pyotherside/Manifest
index eba9498998cc..139447fb794b 100644
--- a/dev-python/pyotherside/Manifest
+++ b/dev-python/pyotherside/Manifest
@@ -1,3 +1,3 @@
DIST pyotherside-1.6.0.tar.gz 183645 BLAKE2B e2a12a9a96f3672a5e322c9f2e84d485b8086bdcacfc6586e0c23f6dd730d3e66cea66618540fd9a304480a9ab86386e2fe0136047c59f70bfa3b5cff9e8e76e SHA512 57835db9d65fae10e6b3ec8ab37793e316324e7a819a1045436adf9eabdee11ccf3090a4db0302283b236e77e5e0bd14cf92ed1430835ccc324e50085a872787
-EBUILD pyotherside-1.6.0.ebuild 1373 BLAKE2B dbc0ce6228273fd98326a0a661c2752c1659a02e578485d1347234d1b45471ce71ddda7d04ed1b4cb136937e6dd8b3cb2cc9ac881f746c50eb55ef1a1d4aa2a9 SHA512 290a247633bbbfb9e8f9528e17a5847fa2cddc8ab54b50e70941c8c3e708d46de03668f564d25134ff78d538a777ae8c2354dd764bb278bd38b5f7a219abcae5
+EBUILD pyotherside-1.6.0.ebuild 1262 BLAKE2B 2bff5a8d65ccfe2b214fc8382ba187cd17afb8cd2b42b03b21597e2169b3113e74c080cc0a9ae7e85ff57d888b127432f0361e99ca9e1b97f68cd3aebfa0feaf SHA512 13411b2916ca77f278643e68951a7f7becb61e59df16e472746aa821d216223bf5254d5e869d925e7d96f3fd3970aeba4cbf7da2c2fc4e5d0db9345ac696d72c
MISC metadata.xml 326 BLAKE2B c323223e1038b40f67b25b1f13a4f5fec61175ef0b73bd3ec3a4228bb51b0a41e0f27ca2f47ec9f2b595e07a83358c74f254054d06b4488ff25d2a1c046899b4 SHA512 9d4649f09f1a00a9aa4a8eeb4e535ceff6b924253cd3ac93a8c0d1f6fe2a94c02a7f14f5b722b7b39744ab7331cd3efb57dc59bcb7ab6fb5ce59f692c0f2718a
diff --git a/dev-python/pyotherside/pyotherside-1.6.0.ebuild b/dev-python/pyotherside/pyotherside-1.6.0.ebuild
index 09ccc8660fa9..41263ea70ea1 100644
--- a/dev-python/pyotherside/pyotherside-1.6.0.ebuild
+++ b/dev-python/pyotherside/pyotherside-1.6.0.ebuild
@@ -20,8 +20,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
^^ ( qt5 qt6 )"
# qt6 TODO:
-# - add dev-qt/qt{gui,opengl}:6 once in the tree, test if qt6 deps okay then
-# - instrument qmake6 (no eqmake6 in the eclass yet)
+# - check if all qt6 deps are okay yet
# - multibuild for both qt5 and qt6 if requested
RDEPEND="
${PYTHON_DEPS}
@@ -33,7 +32,7 @@ RDEPEND="
dev-qt/qtsvg:5
)
qt6? (
- dev-qt/qtbase:6
+ dev-qt/qtbase:6[opengl]
dev-qt/qtdeclarative:6
dev-qt/qtsvg:6
)"
@@ -48,7 +47,7 @@ src_configure() {
if use qt5; then
eqmake5
elif use qt6; then
- die "Qt6 support is not ready yet"
+ eqmake6
else
# This should never happen if REQUIRED_USE is enforced
die "Neither Qt5 nor Qt6 support enabled, aborting"