summaryrefslogtreecommitdiff
path: root/dev-python/pyopenssl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-25 00:48:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-25 00:48:54 +0000
commitb0b85e141f6a9a74d9d6bdce989a626ff5e92523 (patch)
tree18a9a4fc7bf0724456198e68c0012407c085de02 /dev-python/pyopenssl
parent61148529b1734102fa937560847f47719bbd9bd4 (diff)
gentoo auto-resync : 25:03:2023 - 00:48:54
Diffstat (limited to 'dev-python/pyopenssl')
-rw-r--r--dev-python/pyopenssl/Manifest2
-rw-r--r--dev-python/pyopenssl/pyopenssl-23.1.0.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/pyopenssl/Manifest b/dev-python/pyopenssl/Manifest
index 07c7b5131ec7..a933f4930bf5 100644
--- a/dev-python/pyopenssl/Manifest
+++ b/dev-python/pyopenssl/Manifest
@@ -1,3 +1,5 @@
DIST pyOpenSSL-23.0.0.tar.gz 182375 BLAKE2B 8a902ecd7e771dcd281dda184569fef53c7f7d1a801f5cea663ff95014717786ceaaa999b6f67fe710ade253335c856c3964a96705afd6ddb93679856d57d7cd SHA512 68c42de58305461606d9fb932a7711775cfcf1a7c5dbe900b2c7ba18eab546d4c37fcd3dd82ab2c18b15eb07bef126534473b5b29f8af4f46e0147d45ac9e64b
+DIST pyOpenSSL-23.1.0.tar.gz 182977 BLAKE2B 75bb5cf215d17a39d2f11a8948c015766d291ae4c4a9d81f03bc634a0d2abbff78d963d382f858f5609cde3e153fa709ee52c9bcccf0fed35f5f00a18cf4b5e0 SHA512 b46b9a4de7ca584f5711089f1a056c479e65e06b9a0868263aa51b3f724d81342cc89fe06c9eb6e8d44fb87e93c7face9643577145d57608ef6162a5be18127b
EBUILD pyopenssl-23.0.0.ebuild 1577 BLAKE2B a85a483071ae9f2e6cfbdd1f8e8196efef8116944022b38823c5ef366f036872b2eaeaab6172508fe80baa14a4896704266d43e718e8a0195119797ca7812ede SHA512 ab9d2f019236fc8f8f001006907f2ab9539c2b89ab94953f4b7797addc08cc086b65ceccdfa1fef591d8f91563e258966577229777565d9a6d85151f2f291d93
+EBUILD pyopenssl-23.1.0.ebuild 1509 BLAKE2B 2041892115bfe636a1b706ad3abff892f77f103cb493ebba2b72de51023e0186891a0ce412ee4084a9ac3deefb3e1371fddd3bee6baa1b5c23077e61fee89d18 SHA512 7a1988835256389ca10d22e6229c791710583a0151cd5f843a2044a9c6c890652ca6cfac77eb6622064a0775894c14ffebe66a622039571b21e2a06c08477ca7
MISC metadata.xml 536 BLAKE2B 86db822042b6fb3e965ece87b6b15dcabf76cdfbfa76ba285a491208ad5c6a2a196ca7144a1a73b152decc4df1641ad4c57a1cbde9f90d09d25eef1f6f4da39a SHA512 996d0e20291e744c6c20b38fd750d242920541aca7d92de63ca5b1dcc2f1c10308545797ccf499f38e50dfd04db2bb031e93b02c7c1705908f2363c813294ff1
diff --git a/dev-python/pyopenssl/pyopenssl-23.1.0.ebuild b/dev-python/pyopenssl/pyopenssl-23.1.0.ebuild
new file mode 100644
index 000000000000..0e095e2b825a
--- /dev/null
+++ b/dev-python/pyopenssl/pyopenssl-23.1.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+PYPI_NO_NORMALIZE=1
+PYPI_PN=pyOpenSSL
+
+inherit distutils-r1 toolchain-funcs pypi
+
+DESCRIPTION="Python interface to the OpenSSL library"
+HOMEPAGE="
+ https://www.pyopenssl.org/
+ https://github.com/pyca/pyopenssl/
+ https://pypi.org/project/pyOpenSSL/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/cryptography-41[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-38.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+src_test() {
+ local -x TZ=UTC
+ local EPYTEST_DESELECT=(
+ tests/test_ssl.py::TestContext::test_set_default_verify_paths
+ )
+
+ # test for 32-bit time_t
+ "$(tc-getCC)" ${CFLAGS} ${CPPFLAGS} -c -x c - -o /dev/null <<-EOF &>/dev/null
+ #include <sys/types.h>
+ int test[sizeof(time_t) >= 8 ? 1 : -1];
+ EOF
+
+ if [[ ${?} -eq 0 ]]; then
+ einfo "time_t is at least 64-bit long"
+ else
+ einfo "time_t is smaller than 64 bits, will skip broken tests"
+ EPYTEST_DESELECT+=(
+ tests/test_crypto.py::TestX509StoreContext::test_verify_with_time
+ )
+ fi
+
+ distutils-r1_src_test
+}