summaryrefslogtreecommitdiff
path: root/dev-python/pyopenssl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /dev-python/pyopenssl
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'dev-python/pyopenssl')
-rw-r--r--dev-python/pyopenssl/Manifest2
-rw-r--r--dev-python/pyopenssl/pyopenssl-18.0.0.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/pyopenssl/Manifest b/dev-python/pyopenssl/Manifest
index 59327bb9729a..c04f78453921 100644
--- a/dev-python/pyopenssl/Manifest
+++ b/dev-python/pyopenssl/Manifest
@@ -1,3 +1,5 @@
DIST pyOpenSSL-17.5.0.tar.gz 170870 BLAKE2B e8b8986a7c5475ac3898df4877a8be86db359af79e1718bad85149440cff543c501ee23eb369270d2c539a9e3f4e13165ea87b858ef6916ee79ca6e49f6e5370 SHA512 f194662b5842f1e3a4fcb910b9f2e6482d1dcdf834f306acc3dd6d9723f65038f7bff550248fa6268d90c839c9d9e8248bb6c7d399495fe6aed25291b93ece86
+DIST pyOpenSSL-18.0.0.tar.gz 167296 BLAKE2B 3a9c8db02e92858353389508d9791d2ff0b07b54150d27a513b4c26ef62899167d184702cd8ac3a9fb5be120a92e31259ce265a400513de4622c30b1269ecd9f SHA512 7106d4116243a164c1f458ad495564c2cf3a46b4b0fbb1d452b4174ead4409bc9c783c3a4674231ed3c26ecf588077b01dadbdefe033d5e7251a61531c6f6c15
EBUILD pyopenssl-17.5.0.ebuild 1712 BLAKE2B 62870546779662329060ce67ac451909b54191bc844054dd9c9a7e29a5bd77b95164bf894fc657a3f8a765ef29c03f4a6f79fad0076d1d94138dcbb67b7aa8ba SHA512 cea3a766cfcc93739fa2344e870978615bf34aa31d5cca1c043d7ff64817509f2fd88b149a673df832653bd7f2839f68f7028ba48f5e5136233c6c963064cbf1
+EBUILD pyopenssl-18.0.0.ebuild 1726 BLAKE2B 74e3338b662ba17b6ed7edab14096e46c45fc3ecda9e2244155c5e71e4eb0063df3dec9bd4e65cada9ce40c794df53b7ce912477325f74e4bfdb01e03c7d67fb SHA512 e198074650a89311a455268628914100f10c8b436b4a07df73e27aa5c0cf714bd009cf6fd1e1820a16211f256dc66fa5f149798e74af80bfa874c0f316527eac
MISC metadata.xml 418 BLAKE2B 69f135bab3b0cffa47cc8e807e1f537f7fa0bd599bf3309ab92ddf41f894c21ab0e3f793ea4caa65d272043d2dc0352fc54c7160b31fccabbeb165775a895d97 SHA512 5cd4b0381e79245626500a2a38b9f7bedcc8e4742445ac16f12a96133f1291ec49592f2259294f153d5f1b27969cd6f7f364d49f32d0793b12b2ad38b824f441
diff --git a/dev-python/pyopenssl/pyopenssl-18.0.0.ebuild b/dev-python/pyopenssl/pyopenssl-18.0.0.ebuild
new file mode 100644
index 000000000000..f302d4d10277
--- /dev/null
+++ b/dev-python/pyopenssl/pyopenssl-18.0.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN=pyOpenSSL
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python interface to the OpenSSL library"
+HOMEPAGE="
+ http://pyopenssl.sourceforge.net/
+ https://launchpad.net/pyopenssl
+ https://pypi.org/project/pyOpenSSL/
+"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test"
+
+RDEPEND="
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.2.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ virtual/python-cffi[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.0.1[${PYTHON_USEDEP}]
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ # Requires network access
+ sed -i -e 's/test_set_default_verify_paths/_&/' tests/test_ssl.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ TZ=UTC py.test -v || die "Testing failed with ${EPYTHON}" # Fixes bug #627530
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}