summaryrefslogtreecommitdiff
path: root/dev-python/pyopenssl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pyopenssl
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pyopenssl')
-rw-r--r--dev-python/pyopenssl/Manifest4
-rw-r--r--dev-python/pyopenssl/pyopenssl-20.0.1-r1.ebuild (renamed from dev-python/pyopenssl/pyopenssl-20.0.1.ebuild)40
-rw-r--r--dev-python/pyopenssl/pyopenssl-22.0.0.ebuild29
3 files changed, 35 insertions, 38 deletions
diff --git a/dev-python/pyopenssl/Manifest b/dev-python/pyopenssl/Manifest
index 33854b70ffe3..21db044a7229 100644
--- a/dev-python/pyopenssl/Manifest
+++ b/dev-python/pyopenssl/Manifest
@@ -1,5 +1,5 @@
DIST pyOpenSSL-20.0.1.tar.gz 173736 BLAKE2B 37e1741425a296142d38c20c70f9950eec2bd043fc58e50c9955b98dc6825111328af852d247b154aa120ab42ea9dc2ae8186d350dd0c664cd5920b9a902963e SHA512 e81e0870398b882d77453b02e972559c0be82dbfe87bd8a48a65e8943acc3ea07dc8c3150b88e299c237496043443d1a5832219c337e4436f99ef419b36dd23f
DIST pyOpenSSL-22.0.0.tar.gz 178438 BLAKE2B d34c91a54aaf6b28d92ba83c26900fb308835512275267e11a5482ede4ab45177434559a53c64a116aa19c84d65dcdb459aecd3fc5587cb13e21cd2f196a0078 SHA512 3d7695f27b7909eb82f05527ab7551fe90a85a70f20ea980293b59672a62f9b015966180407fa0786e94b01ad1d1acfaa7d40426bb63410efd24a144e559e2f0
-EBUILD pyopenssl-20.0.1.ebuild 1812 BLAKE2B 2a2cc8e08f97fea2586d96521c2a47d6464ea0bac973ae49505c05f9c3436369b3867c6a353f7a83f993bccd2eeb11b999fc33c93dcf6d7c3e0448ad6c408318 SHA512 194f7d3330d4f66b4144a7aa520f817a9fb4dd273dbc833dedba6c8cf16fc03c3d0331b2adfbd5b9c55aa029eae613884382b64604816c2c2b26f45b1c773d55
-EBUILD pyopenssl-22.0.0.ebuild 1624 BLAKE2B ef6deeabe15a07739f4765b4220ffbfed85e7dc37cad202c342965d67f8214d2d6443e3ac4e4602da4498495ad4dfff121726e7164001e54207930f18d39d46a SHA512 2ccfaba1e5918ae89903d8dd8ec8a3f8051c166d9690256b07a2c9a4a4cf5d208fca24fee9475246a7145fa7e1ae04aacbc00499f9087a99fb2271adc822e4f4
+EBUILD pyopenssl-20.0.1-r1.ebuild 1722 BLAKE2B d72fda3e356d0890e501a924e57eb92bf7adbffa5e18dc0727785a54eae14946f182b37d1adc77cdb90fe0e53b99453b9c55e78622d0c0fcb93b011ef0f8d94b SHA512 fb4aa69b3ff9b0e29bd97b9ddc9ade6391adafbbcb3d8f65f1476fb716a2b2ac1c67e9b45827348f87c40b8e7ef932804ff23323640474f19b95e1b0ca483080
+EBUILD pyopenssl-22.0.0.ebuild 1516 BLAKE2B 8811d78556c845f9dacecab431ec199e04a3eeb03daf2c9504a7d82bea6435788e93a2f14d003a90366ce32fc837973caa05fe8de87cbe181f879be3d375479f SHA512 5272324ac16dfbdb1697a1a7f65dbfe18a1d1e80bf46e10e0148a9992159cdf8f44fc681ce62d9bd29644d018e1a79d58a4068d9288cd36c8ec64e6506a498c3
MISC metadata.xml 536 BLAKE2B 86db822042b6fb3e965ece87b6b15dcabf76cdfbfa76ba285a491208ad5c6a2a196ca7144a1a73b152decc4df1641ad4c57a1cbde9f90d09d25eef1f6f4da39a SHA512 996d0e20291e744c6c20b38fd750d242920541aca7d92de63ca5b1dcc2f1c10308545797ccf499f38e50dfd04db2bb031e93b02c7c1705908f2363c813294ff1
diff --git a/dev-python/pyopenssl/pyopenssl-20.0.1.ebuild b/dev-python/pyopenssl/pyopenssl-20.0.1-r1.ebuild
index eadda66ac57d..6ae449eb04e1 100644
--- a/dev-python/pyopenssl/pyopenssl-20.0.1.ebuild
+++ b/dev-python/pyopenssl/pyopenssl-20.0.1-r1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1 toolchain-funcs
@@ -26,20 +27,28 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv
RDEPEND="
>=dev-python/six-1.5.2[${PYTHON_USEDEP}]
- >=dev-python/cryptography-3.2[${PYTHON_USEDEP}]"
+ >=dev-python/cryptography-3.2[${PYTHON_USEDEP}]
+"
BDEPEND="
test? (
- virtual/python-cffi[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
dev-python/flaky[${PYTHON_USEDEP}]
dev-python/pretend[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.0.1[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_sphinx doc \
dev-python/sphinx_rtd_theme
distutils_enable_tests pytest
-src_configure() {
+src_test() {
+ local -x TZ=UTC
+ local EPYTEST_DESELECT=(
+ tests/test_ssl.py::TestContext::test_set_default_verify_paths
+ )
+
# test for 32-bit time_t
"$(tc-getCC)" ${CFLAGS} ${CPPFLAGS} -c -x c - -o /dev/null <<-EOF &>/dev/null
#include <sys/types.h>
@@ -47,22 +56,13 @@ src_configure() {
EOF
if [[ ${?} -eq 0 ]]; then
- PYOPENSSL_SKIP_LARGE_TIME=
einfo "time_t is at least 64-bit long"
else
- PYOPENSSL_SKIP_LARGE_TIME=1
einfo "time_t is smaller than 64 bits, will skip broken tests"
+ EPYTEST_DESELECT+=(
+ tests/test_crypto.py::TestX509StoreContext::test_verify_with_time
+ )
fi
-}
-
-python_test() {
- local -x TZ=UTC
- local deselect=(
- tests/test_ssl.py::TestContext::test_set_default_verify_paths
- )
- [[ ${PYOPENSSL_SKIP_LARGE_TIME} ]] && deselect+=(
- tests/test_crypto.py::TestX509StoreContext::test_verify_with_time
- )
- epytest ${deselect[@]/#/--deselect }
+ distutils-r1_src_test
}
diff --git a/dev-python/pyopenssl/pyopenssl-22.0.0.ebuild b/dev-python/pyopenssl/pyopenssl-22.0.0.ebuild
index c2f361933d05..f03b92cd9574 100644
--- a/dev-python/pyopenssl/pyopenssl-22.0.0.ebuild
+++ b/dev-python/pyopenssl/pyopenssl-22.0.0.ebuild
@@ -4,13 +4,14 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1 toolchain-funcs
MY_PN=pyOpenSSL
MY_P=${MY_PN}-${PV}
+
DESCRIPTION="Python interface to the OpenSSL library"
HOMEPAGE="
https://www.pyopenssl.org/
@@ -22,7 +23,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv x86"
RDEPEND="
>=dev-python/cryptography-35.0[${PYTHON_USEDEP}]
@@ -41,7 +42,12 @@ distutils_enable_sphinx doc \
dev-python/sphinx_rtd_theme
distutils_enable_tests pytest
-src_configure() {
+src_test() {
+ local -x TZ=UTC
+ local EPYTEST_DESELECT=(
+ tests/test_ssl.py::TestContext::test_set_default_verify_paths
+ )
+
# test for 32-bit time_t
"$(tc-getCC)" ${CFLAGS} ${CPPFLAGS} -c -x c - -o /dev/null <<-EOF &>/dev/null
#include <sys/types.h>
@@ -49,22 +55,13 @@ src_configure() {
EOF
if [[ ${?} -eq 0 ]]; then
- PYOPENSSL_SKIP_LARGE_TIME=
einfo "time_t is at least 64-bit long"
else
- PYOPENSSL_SKIP_LARGE_TIME=1
einfo "time_t is smaller than 64 bits, will skip broken tests"
+ EPYTEST_DESELECT+=(
+ tests/test_crypto.py::TestX509StoreContext::test_verify_with_time
+ )
fi
-}
-
-python_test() {
- local -x TZ=UTC
- local EPYTEST_DESELECT=(
- tests/test_ssl.py::TestContext::test_set_default_verify_paths
- )
- [[ ${PYOPENSSL_SKIP_LARGE_TIME} ]] && EPYTEST_DESELECT+=(
- tests/test_crypto.py::TestX509StoreContext::test_verify_with_time
- )
- epytest
+ distutils-r1_src_test
}