summaryrefslogtreecommitdiff
path: root/dev-python/pyopencl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-21 20:55:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-21 20:55:01 +0100
commiteb509e1a15f595f667e8d177ddb73311084af6c0 (patch)
treefbc083f793d438d54b7fb4ec3a7e0286701b81bb /dev-python/pyopencl
parenteedf7b9dec39b69b43f7b581da418d37428db449 (diff)
gentoo auto-resync : 21:05:2023 - 20:55:01
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest2
-rw-r--r--dev-python/pyopencl/pyopencl-2023.1.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index 0d9365bed43f..21fbf21e07e0 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,3 +1,5 @@
DIST pyopencl-2022.3.1.tar.gz 470441 BLAKE2B 86ec602f3d73a64e34fe77b7985e64db332a685b33231ad7832d7e864f3170e3eee0aed42742b9892f7950a0f672a736e169ccd0ca08a124b7f20738b348dbff SHA512 57944de69bb24f0f22fb2c0165cd4de5265f5329246fead8449d26e6cbe1204fd44ced70df9960aa54e7d285abe81d8f8a802ba62309de5f4865e882177025ae
+DIST pyopencl-2023.1.tar.gz 472581 BLAKE2B bfa25646b00b8d5c1a2fb7b98c18383e3013b9aa1573dc1bcbc1e056d3bd50d48fb35b7b74c4d87c079fe9334817ff325edd235bdd0de610373850c3ab057773 SHA512 3a6c61715338b31f9e9c3b9c8afe029e63d2689f9d52174c91cfe7383425643b3d08f5c125ab7e24ca776c86ff19d5adb7bfe56f1bd531ba443f99dcf9449244
EBUILD pyopencl-2022.3.1.ebuild 1999 BLAKE2B d64eb47dc442534e666b141e7d02bde62d80ead50d74cbde05dc32b28b143f20e1e6ceab3c199720ae07fa4e26272c034484ee8cd2962ba98dfc9f5db9cf4346 SHA512 d339449a1043befbf8eacbdb9f6874b16be9b54fcc17c0c1070ac4176fccdc04fb488dcef44555031d5aed30179bb3a74684240ec980dc66c67b7b63be1f34ac
+EBUILD pyopencl-2023.1.ebuild 2000 BLAKE2B 1ce9363a3312a5a93a0f970fb9c3cb4dbc87e9e597039a71afcf26833ce7d772bb97abf694ea66472856cb49302a5f8c6d458d52c554c3fdf58aa42fdfe8b3de SHA512 23074496a74fe4f67ec91821a00b7c2cfc360e3cd936c354e581edc0b7a58ea7aaee7d01390cb002be4e8f02c0aefec9f438a7d0e0968b10382ddbeee603d50e
MISC metadata.xml 373 BLAKE2B 0de89cb91a5dba1c34bacf04a95d4e2eb9e903bfb55e291f2ed20d579b9736a9a25f27620eed05d19c903c117e0dfbf410f408e9ff4008ce8c93f7b1b004141e SHA512 4ff5643089e5590d1ae4ef413a1ab0fa2772f71922a9da2c8b43ae375ba2e6e3d95ab90a13d51d22fdea49663c112c36352df609eceebd520fdc06590907b0e7
diff --git a/dev-python/pyopencl/pyopencl-2023.1.ebuild b/dev-python/pyopencl/pyopencl-2023.1.ebuild
new file mode 100644
index 000000000000..50170e58a2a8
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2023.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="
+ https://mathema.tician.de/software/pyopencl/
+ https://pypi.org/project/pyopencl/
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="examples opengl"
+
+# Running tests on GPUs requires both appropriate hardware and additional permissions
+# having been granted to the user running them. Testing on CPUs with dev-libs/pocl
+# is in theory possible but has been found to be very fragile, see e.g. Bug #872308.
+RESTRICT="test"
+
+COMMON=">=virtual/opencl-2"
+# libglvnd is only needed for the headers
+DEPEND="${COMMON}
+ opengl? ( media-libs/libglvnd )"
+RDEPEND="${COMMON}
+ >=dev-python/mako-0.3.6[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.5.0[${PYTHON_USEDEP}]
+ test? ( dev-libs/pocl )"
+
+distutils_enable_tests pytest
+
+python_configure_all() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${EPYTHON}" configure.py \
+ "${myconf[@]}"
+}
+
+python_test() {
+ # Use dev-libs/pocl for testing; ignore any other OpenCL devices that might be present
+ local -x PYOPENCL_TEST="portable:pthread"
+ # Set the number of threads to match MAKEOPTS
+ local -x POCL_MAX_PTHREAD_COUNT=$(makeopts_jobs)
+ # Change to the 'test' directory so that python does not try to import pyopencl from the source directory
+ # (Importing from the source directory fails, because the compiled '_cl' module is only in the build directory)
+ pushd test >/dev/null || die
+ epytest
+ popd >/dev/null || die
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}