summaryrefslogtreecommitdiff
path: root/dev-python/pyopencl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-26 02:47:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-26 02:47:53 +0100
commitc3a905eafd0ea87d50767fa3d24a6b565a41faa9 (patch)
tree8fcd60c2f36e3da5e4d545f47ddf14680f0d51e5 /dev-python/pyopencl
parent159ec3f090554ee5d7f61b2da553833fb7566f99 (diff)
gentoo auto-resync : 26:10:2023 - 02:47:53
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest2
-rw-r--r--dev-python/pyopencl/pyopencl-2023.1.4.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index 7d73e3081f61..3c86dc6f192e 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,4 +1,6 @@
AUX pyopencl-2023.1.2_numpy-include-dir.patch 409 BLAKE2B 54b6f0618d1988d7bb83f42b289d4eea30bce992a757a20d2d6e401261497ed4a2e1a302f5b59d840d64b9f5649c0b3f137eb98634ee2122d695177c161d9a46 SHA512 672f4fbe11fa91bbce354898f5beda783e9fe907614b336b5dfee5dfbf5ef4e82cb9b70d7e9866c221f2044a06e5ea9c630adfdd0db3c1c46233debb1f0203c3
DIST pyopencl-2023.1.2.tar.gz 473684 BLAKE2B 3912885395df515f3e935149c0bac618c371b75791ac670d1a2cd25ffe5e3ff1c4d0e82d8a475e26d3280aaa659d900ed7df66b3f6952f54266d3cd2ad3b44c2 SHA512 3414b011f0bd0420df4725904b715d54bad0ae77cb4b8619d8d769cd25b56d44a8d34788c23de80b5da5ae757f38231db980f3abcb2544117b7be7627592bf0e
+DIST pyopencl-2023.1.4.tar.gz 473899 BLAKE2B 7d836d77b14f89b6dbf0dd2a189f3cb9442f224ff5c9c9db902aa93dc582278450b3d47576885bbe3738ee25f979a260d5c6f906366279adc30be7d3cc3545e1 SHA512 2508d21856d9b846bce14bcd11d007eedddc1cc5c1ce9f8d2ac18743ab9aa5d673c85792b535779b2f414caf47e39ed53c07d7ee8a061bcfa020a15f59463861
EBUILD pyopencl-2023.1.2.ebuild 2090 BLAKE2B 923ac4ba365b02e0f8e8d89597265471be8203764ea6efb1a60358e98a51103ad7c2b20d1bc313e9d079f24da694047836a2c587b08a773d4dbab845a262e71a SHA512 cfe1756f3b55b2e3daf6b1f86d8f5ba00e531db63880cfcfb4405e39e9c5db0365b8243a94c68afa5391b639c2caad5cbfcdd2bbd85a6058344508c5add698ac
+EBUILD pyopencl-2023.1.4.ebuild 2024 BLAKE2B 27e7137ab55372209e17346703faf59fd61ee12d82ed12d9601055c8fbef378a8a2b26291af468f8c826802cdc23b2a69a55cf7f0187f1e88fb8ba64a78bc568 SHA512 b7a019902bc25d07bb437126c8246cba7a0c27a9b44d437bea4b64882899ae81617afbe97ec46fa70d4aaec4e217ba0ed70caf408d8b938b6891df99d5b837e3
MISC metadata.xml 373 BLAKE2B 0de89cb91a5dba1c34bacf04a95d4e2eb9e903bfb55e291f2ed20d579b9736a9a25f27620eed05d19c903c117e0dfbf410f408e9ff4008ce8c93f7b1b004141e SHA512 4ff5643089e5590d1ae4ef413a1ab0fa2772f71922a9da2c8b43ae375ba2e6e3d95ab90a13d51d22fdea49663c112c36352df609eceebd520fdc06590907b0e7
diff --git a/dev-python/pyopencl/pyopencl-2023.1.4.ebuild b/dev-python/pyopencl/pyopencl-2023.1.4.ebuild
new file mode 100644
index 000000000000..2e70bde9cbd6
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2023.1.4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="
+ https://mathema.tician.de/software/pyopencl/
+ https://pypi.org/project/pyopencl/
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv"
+IUSE="examples opengl"
+
+# Running tests on GPUs requires both appropriate hardware and additional permissions
+# having been granted to the user running them. Testing on CPUs with dev-libs/pocl
+# is in theory possible but has been found to be very fragile, see e.g. Bug #872308.
+RESTRICT="test"
+
+COMMON=">=virtual/opencl-2"
+# libglvnd is only needed for the headers
+DEPEND="${COMMON}
+ opengl? ( media-libs/libglvnd )"
+RDEPEND="${COMMON}
+ >=dev-python/mako-0.3.6[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.5.0[${PYTHON_USEDEP}]
+ test? ( dev-libs/pocl )"
+
+distutils_enable_tests pytest
+
+python_configure_all() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${EPYTHON}" configure.py \
+ "${myconf[@]}"
+}
+
+python_test() {
+ # Use dev-libs/pocl for testing; ignore any other OpenCL devices that might be present
+ local -x PYOPENCL_TEST="portable:pthread"
+ # Set the number of threads to match MAKEOPTS
+ local -x POCL_MAX_PTHREAD_COUNT=$(makeopts_jobs)
+ # Change to the 'test' directory so that python does not try to import pyopencl from the source directory
+ # (Importing from the source directory fails, because the compiled '_cl' module is only in the build directory)
+ pushd test >/dev/null || die
+ epytest
+ popd >/dev/null || die
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}