summaryrefslogtreecommitdiff
path: root/dev-python/pyopencl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-python/pyopencl
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest2
-rw-r--r--dev-python/pyopencl/pyopencl-2021.1.3.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index 56be3b40ebd2..2cb728d62e30 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,3 +1,5 @@
DIST pyopencl-2020.3.1.tar.gz 357422 BLAKE2B de9cb6408e957e30f54797ce682ed17f3272dc82019bcd9a744a0696a7e344f47645a3549332da90e0bcc442f7a8ea9c6a12a375875a9728fa9814ca9d1a9b30 SHA512 459d6f060f4203e83276c47bf832f33fc4348dd59904ea55fe2a53684cb7c8eaad45875476d10dcb6653820f9cb1f7e013c6b854410b2040b2dfe847fc1f7658
+DIST pyopencl-2021.1.3.tar.gz 447070 BLAKE2B fcd8c5d06de9c14a7bcf3c3d37f89cb208adf0225cc88a081aefc86aac82a99026183f2c9975f34cd8247f784335e4ba6c0a09164ce01e527123b5c1dd952a76 SHA512 8799e73b3b1596387f619fd997f643228679fb1d9ab5ce6704da9df51922f96229efc98ab6b7a7361234848078b15bc67946a4188f4d17cb8760040b48b346e8
EBUILD pyopencl-2020.3.1.ebuild 1458 BLAKE2B 813176a34b1b1d3110bcd6535e9a9036bc62b720c7b24926e791437ac1ae9cfc5e08705632a1ce059f2ee9e7d7917d0b0d22310200d90967e734202e8f2f2abf SHA512 f163387b2fe9a65dd52b94c5d5f2c12c4a105cbfc47f5d4c2bbf3327668f0bd646ee0af37e737fbb862f278d0e239e503d29992fd9ca44bf87a23c0d743cb2f4
+EBUILD pyopencl-2021.1.3.ebuild 1459 BLAKE2B 59d479bafd5c8631579ae52b0d1ee05da5580223dae30fc56c71b6f8174f7a04743a3ca7f41adb53cb7e3eb4681d43200a91b7158bb48cd0e21174d4443375c0 SHA512 1c338fba025f055da1dd75891f90898ff36cc8976ba1a34ae0c6b0157d5c5c5f53799d92bfaf01839a45940f09f8000bf213658a3e315134c85bbaae6bc1974b
MISC metadata.xml 316 BLAKE2B 46de5d09541dbd7e1ae6cb3e46a87f0f7dde068ca48dfb4f8885b3f25a2c6ad258019a7585bc6dac42a01ce41292d5458aa7ba122fd81a1fe6f12307b0642966 SHA512 1ac69571c5ff5abb94dc68dc87d02d8675e12e120dedb0bece65a9cb81764f496a587e7345b43e8037f8d7ed6e269dfa276d8482ab42fdb4f3adda336570d703
diff --git a/dev-python/pyopencl/pyopencl-2021.1.3.ebuild b/dev-python/pyopencl/pyopencl-2021.1.3.ebuild
new file mode 100644
index 000000000000..a9a305e869f5
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2021.1.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="https://mathema.tician.de/software/pyopencl/
+ https://pypi.org/project/pyopencl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples opengl"
+
+COMMON="dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${COMMON}
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2017.6[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=virtual/opencl-2"
+DEPEND="${COMMON}
+ dev-python/pybind11[${PYTHON_USEDEP}]"
+
+# The test suite fails if there are no OpenCL platforms available, and
+# even if there is one (which requires the presence of both an OpenCL
+# runtime *and* hardware supported by it - simply emerging any runtime
+# is not enough) the vast majority of tests end up skipped because by
+# default the portage user hasn't got sufficient privileges to talk
+# to the GPU.
+RESTRICT="test"
+
+python_configure_all() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${EPYTHON}" configure.py \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}