summaryrefslogtreecommitdiff
path: root/dev-python/pyopencl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-python/pyopencl
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest2
-rw-r--r--dev-python/pyopencl/pyopencl-2021.2.11.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index e975ea91690c..cf7641de5ea7 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,3 +1,5 @@
+DIST pyopencl-2021.2.11.tar.gz 452225 BLAKE2B 48ea9a96e23370f4a8b40b5c43f439bc0635764b577ee554f9b65e8a1a790b3a90c4c4c2167d8c32c6f926ca6fa77c035542d503a14ea7c12470cbb73c99d7ba SHA512 584419da05a06b94d2bbb89072ef37007176a978aebf42a5d46eb3c0daf90119a585c60ecef34108ec60f8f98a6ec6e54e00dcac474bc42ddb43211c2b21d161
DIST pyopencl-2021.2.9.tar.gz 451109 BLAKE2B a4b9b1ee1bd4f42742aa2de3acb3f5fe54771905f15dc002327a6669bf460c825c81729403df0b98537deb91ca9d0fa8dd30dd8d7e718fcc23a256b6a797484b SHA512 557bdf20df97090557f441f47b31d5b2878341fe670a4e64a563d8a464fdd5915ece651103ed17396248ab174b1895f4841e5b7ac803b8bf6286266e2c4366d6
+EBUILD pyopencl-2021.2.11.ebuild 1489 BLAKE2B 2bba779fbd0f2b526a369b5bd6ac9b4b6dedba9dc395b4ccea39df310df268d5a825bdd51c431393a960d37b9d59c2fee7f79d91bcbfc8598074dd995aca6277 SHA512 c50235f4fc323817a2e6b8191666189fe9dc3c612c0257fb42ac4428685dedc110799644c6e8fc492de1d81e83cac649432e5557177e0eb49fbf0dd35ac74a1f
EBUILD pyopencl-2021.2.9.ebuild 1488 BLAKE2B 41b71520729ba3c89600f89c4c1697d4c3ab7c2b504004fbda014f6fabc4ba4d08da36f5111af0a15aba68c8a252b840ef2c7b1297b5908ec602ce257e4d3853 SHA512 290e0c5d41be5e1727bdb1d8989b77d07a4db8009e093329b84e8b1f331d158ac04d52646cad9e064ad2b8d800f4c777d4f0660773125137ae876d8547d7c419
MISC metadata.xml 317 BLAKE2B ba532c522d5fd599dfd41180c9813f8124dc64cd3bc7a3a7b1ecdc121b216db4b43f6cae9c32c52a430fbf6e9a22c0cf27ffaf0041ca372d81666991bcf0e979 SHA512 845a8b83a5d7729ea0fca8b704de297b8b8c0d8f315fad0bea7c0c645bc79dd993209e9ca5e89ec9c8ddbe6db2b1f142c3e1f7e5b8e4b6259fe927527ce6a919
diff --git a/dev-python/pyopencl/pyopencl-2021.2.11.ebuild b/dev-python/pyopencl/pyopencl-2021.2.11.ebuild
new file mode 100644
index 000000000000..3430d722f4e2
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2021.2.11.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="https://mathema.tician.de/software/pyopencl/
+ https://pypi.org/project/pyopencl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples opengl"
+
+DEPEND=">=virtual/opencl-2"
+RDEPEND="${DEPEND}
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/mako-0.3.6[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]"
+# libglvnd is only needed for the headers
+BDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.5.0[${PYTHON_USEDEP}]
+ opengl? ( media-libs/libglvnd )"
+
+# The test suite fails if there are no OpenCL platforms available, and
+# even if there is one (which requires the presence of both an OpenCL
+# runtime *and* hardware supported by it - simply emerging any runtime
+# is not enough) the vast majority of tests end up skipped because by
+# default the portage user hasn't got sufficient privileges to talk
+# to the GPU.
+RESTRICT="test"
+
+python_configure_all() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${EPYTHON}" configure.py \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}