summaryrefslogtreecommitdiff
path: root/dev-python/pyopencl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/pyopencl
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest2
-rw-r--r--dev-python/pyopencl/pyopencl-2021.2.9.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index d89704a08bd3..19d6ee9de807 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,3 +1,5 @@
DIST pyopencl-2021.2.6.tar.gz 450194 BLAKE2B be9d0bf653f77d33a4337deab9189a5a9031ff50526444283c6fb9f8625d0451cb211ff703b5eb86c18beebb973f8f7a7cc93da3efc6bb4e95cd533d633fde93 SHA512 b7bea4903a34104c538545c611554c1651ae7a94ee56d8c7129a88a9e547911fac085617b4238fac33534c9b981bcfdb9fabd716456a86fa428cfd42d9cb128c
+DIST pyopencl-2021.2.9.tar.gz 451109 BLAKE2B a4b9b1ee1bd4f42742aa2de3acb3f5fe54771905f15dc002327a6669bf460c825c81729403df0b98537deb91ca9d0fa8dd30dd8d7e718fcc23a256b6a797484b SHA512 557bdf20df97090557f441f47b31d5b2878341fe670a4e64a563d8a464fdd5915ece651103ed17396248ab174b1895f4841e5b7ac803b8bf6286266e2c4366d6
EBUILD pyopencl-2021.2.6.ebuild 1404 BLAKE2B 3db690ddda606ff83eba51220b40a148da79f75b91e26586e7c8c4e726888821e5181f1742662206eedfeba8defc7bae36547ed2955512b8f1bf6a818a38719f SHA512 f14f35bf7be814dca5e424c25493f6cd94aa40f008e3ed66e073eb628f76ac7417f8e7433eef488242ea61a37760e5fe45595c097c17dac73b3b8b34a6390f46
+EBUILD pyopencl-2021.2.9.ebuild 1489 BLAKE2B 1fa06ab0127216396313b378415d5e917f9f87970cbd11325d64198f89053e380f41fc18d44cde993909bea9c0d85f81cdf6a3d6b805508d2f233ceec114e01e SHA512 d927ed52efd885d4ad6744754e1da43897f4baf672912ec54f7ac94b731ba08520536ef5c5e78c93108a9b5b30de43120127d3b88d2b678a6a62d658f070b066
MISC metadata.xml 317 BLAKE2B ba532c522d5fd599dfd41180c9813f8124dc64cd3bc7a3a7b1ecdc121b216db4b43f6cae9c32c52a430fbf6e9a22c0cf27ffaf0041ca372d81666991bcf0e979 SHA512 845a8b83a5d7729ea0fca8b704de297b8b8c0d8f315fad0bea7c0c645bc79dd993209e9ca5e89ec9c8ddbe6db2b1f142c3e1f7e5b8e4b6259fe927527ce6a919
diff --git a/dev-python/pyopencl/pyopencl-2021.2.9.ebuild b/dev-python/pyopencl/pyopencl-2021.2.9.ebuild
new file mode 100644
index 000000000000..95577e0b236f
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2021.2.9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="https://mathema.tician.de/software/pyopencl/
+ https://pypi.org/project/pyopencl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples opengl"
+
+DEPEND=">=virtual/opencl-2"
+RDEPEND="${DEPEND}
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/mako-0.3.6[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]"
+# libglvnd is only needed for the headers
+BDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.5.0[${PYTHON_USEDEP}]
+ opengl? ( media-libs/libglvnd )"
+
+# The test suite fails if there are no OpenCL platforms available, and
+# even if there is one (which requires the presence of both an OpenCL
+# runtime *and* hardware supported by it - simply emerging any runtime
+# is not enough) the vast majority of tests end up skipped because by
+# default the portage user hasn't got sufficient privileges to talk
+# to the GPU.
+RESTRICT="test"
+
+python_configure_all() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${EPYTHON}" configure.py \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}