summaryrefslogtreecommitdiff
path: root/dev-python/pyopencl/pyopencl-2017.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pyopencl/pyopencl-2017.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pyopencl/pyopencl-2017.2.ebuild')
-rw-r--r--dev-python/pyopencl/pyopencl-2017.2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pyopencl/pyopencl-2017.2.ebuild b/dev-python/pyopencl/pyopencl-2017.2.ebuild
new file mode 100644
index 000000000000..f61d50f65f40
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2017.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="http://mathema.tician.de/software/pyopencl https://pypi.python.org/pypi/pyopencl"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples opengl"
+
+RDEPEND="
+ >=dev-libs/boost-1.48[python,${PYTHON_USEDEP}]
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]
+ >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2015.1.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=virtual/opencl-0-r1"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${PYTHON}" configure.py \
+ --boost-compiler=gcc \
+ --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
+ --no-use-shipped-boost \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ local EXAMPLES=( examples/. )
+ einfo "Some of the examples provided by this package require dev-python/matplotlib."
+ fi
+ distutils-r1_python_install_all
+}