summaryrefslogtreecommitdiff
path: root/dev-python/pyopencl/pyopencl-2017.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/pyopencl/pyopencl-2017.2.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyopencl/pyopencl-2017.2.ebuild')
-rw-r--r--dev-python/pyopencl/pyopencl-2017.2.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/pyopencl/pyopencl-2017.2.ebuild b/dev-python/pyopencl/pyopencl-2017.2.ebuild
deleted file mode 100644
index 4c58f1356850..000000000000
--- a/dev-python/pyopencl/pyopencl-2017.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="https://mathema.tician.de/software/pyopencl
- https://pypi.org/project/pyopencl/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="examples opengl"
-
-RDEPEND="
- >=dev-libs/boost-1.48[python,${PYTHON_USEDEP}]
- >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]
- >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/pytools-2015.1.2[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=virtual/opencl-0-r1"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- local myconf=()
- if use opengl; then
- myconf+=(--cl-enable-gl)
- fi
-
- "${PYTHON}" configure.py \
- --boost-compiler=gcc \
- --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
- --no-use-shipped-boost \
- "${myconf[@]}"
-}
-
-python_install_all() {
- if use examples; then
- local EXAMPLES=( examples/. )
- einfo "Some of the examples provided by this package require dev-python/matplotlib."
- fi
- distutils-r1_python_install_all
-}