summaryrefslogtreecommitdiff
path: root/dev-python/pyoembed
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyoembed
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyoembed')
-rw-r--r--dev-python/pyoembed/Manifest4
-rw-r--r--dev-python/pyoembed/metadata.xml19
-rw-r--r--dev-python/pyoembed/pyoembed-0.1.1.ebuild34
-rw-r--r--dev-python/pyoembed/pyoembed-9999.ebuild34
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/pyoembed/Manifest b/dev-python/pyoembed/Manifest
new file mode 100644
index 000000000000..4f8d498d2a0f
--- /dev/null
+++ b/dev-python/pyoembed/Manifest
@@ -0,0 +1,4 @@
+DIST pyoembed-0.1.1.tar.gz 12941 BLAKE2B 0a3a5935e599450441e661b124034be36a0d3c529b936d9a8cacf997870d83f89a2d067f250902043efd07a44b56a7b3e10524dcf51dea603a033ece47200c23 SHA512 6ce7ec87082179c0f35dffe67f7ce91b71c40c57ed6bf7bd0ecd2ce654fbd1ab0c6f6469cbfb4e0a8dafc970bf496ffbc57f09838cf575e0becf7527553de63e
+EBUILD pyoembed-0.1.1.ebuild 752 BLAKE2B ba58993272b2281fb23141803041a0fec5872764112695a7b170ac179907016497ce7c13e6f327d85c23e602f74f9ab3f75d11f90cb8522b23a00b35376d679b SHA512 c32c70ead9ade63b7e65e36174329ff5bffa632fce01e45230dffc8c0f32ae85dea3a7cb87b2c27b4b163a6d08cd6cbfb63a53380257f03daa9ddcb10640deb4
+EBUILD pyoembed-9999.ebuild 752 BLAKE2B ba58993272b2281fb23141803041a0fec5872764112695a7b170ac179907016497ce7c13e6f327d85c23e602f74f9ab3f75d11f90cb8522b23a00b35376d679b SHA512 c32c70ead9ade63b7e65e36174329ff5bffa632fce01e45230dffc8c0f32ae85dea3a7cb87b2c27b4b163a6d08cd6cbfb63a53380257f03daa9ddcb10640deb4
+MISC metadata.xml 656 BLAKE2B 955e14f70cc8b4c92a51d362931dc8efb23a0ef24ee6616857456e8eda68ae4e8cc2ffff6bc1ab9eabb141786d158243ee40c211683e181b4321e09d1d53e2f9 SHA512 65a38eadbd1450933b37c210be72d594943761bf0fa543e20e9364e97d8e14ec3722906c653842fb1ea47fdbd58851a208cfd124630afad2e25f00d74e585bd5
diff --git a/dev-python/pyoembed/metadata.xml b/dev-python/pyoembed/metadata.xml
new file mode 100644
index 000000000000..20911663d8b3
--- /dev/null
+++ b/dev-python/pyoembed/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <longdescription lang="en">
+ A Python library for oEmbed that supports auto-discovered and manually included providers.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <remote-id type="pypi">pyoembed</remote-id>
+ <remote-id type="github">rafaelmartins/pyoembed</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyoembed/pyoembed-0.1.1.ebuild b/dev-python/pyoembed/pyoembed-0.1.1.ebuild
new file mode 100644
index 000000000000..3b6c54f2f8c2
--- /dev/null
+++ b/dev-python/pyoembed/pyoembed-0.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for oEmbed with auto-discovered and manually added providers"
+HOMEPAGE="https://github.com/rafaelmartins/pyoembed"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=
+ KEYWORDS=
+ EGIT_REPO_URI="https://github.com/rafaelmartins/pyoembed.git"
+ inherit git-r3
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/pyoembed/pyoembed-9999.ebuild b/dev-python/pyoembed/pyoembed-9999.ebuild
new file mode 100644
index 000000000000..3b6c54f2f8c2
--- /dev/null
+++ b/dev-python/pyoembed/pyoembed-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for oEmbed with auto-discovered and manually added providers"
+HOMEPAGE="https://github.com/rafaelmartins/pyoembed"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=
+ KEYWORDS=
+ EGIT_REPO_URI="https://github.com/rafaelmartins/pyoembed.git"
+ inherit git-r3
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}