summaryrefslogtreecommitdiff
path: root/dev-python/pyode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyode
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyode')
-rw-r--r--dev-python/pyode/Manifest3
-rw-r--r--dev-python/pyode/metadata.xml11
-rw-r--r--dev-python/pyode/pyode-1.2.0_p20100322-r1.ebuild43
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pyode/Manifest b/dev-python/pyode/Manifest
new file mode 100644
index 000000000000..d8fb2b8b9a12
--- /dev/null
+++ b/dev-python/pyode/Manifest
@@ -0,0 +1,3 @@
+DIST PyODE-snapshot-2010-03-22.tar.bz2 55651 BLAKE2B 4ef1337f4a4c7e2bcbece57af0eff4d2da08dce1ad63d6772fe76a473559a7b102c8282ada3abf2add2b78e8609ca3fc3d67e3f520bdda4186ff6a854b4a5012 SHA512 fd9457d9a9c42a5e9834ce45886d6b57c9ecfdc68868353d986fa219eb57246d4dc175ca5d12c876c359c5bdac5bcdaf6dfc2ee65fff52f53337b1d10458e54c
+EBUILD pyode-1.2.0_p20100322-r1.ebuild 1097 BLAKE2B b86d914c033582c0337ff66eb086b7f9eeea277dab7d60afd931e71344b1d77ca2b6f8b138a31202d0a4f49f6935d95c019006412d1bcbc0dda7f32f3ccb8181 SHA512 cbf3345ec418b1aa0aa361884f0b9b4fc3fdad7b43e3fc73a21b8cfc2122b7c58440a9119f227a1fe8bf72c4f688fbb8330efda3334f53be2691370fa0ea595d
+MISC metadata.xml 315 BLAKE2B 152961e59a3cc5114f7372f271e7877477ec2e976a2ecd8ea0e7000ac512e569453da3316344deca3b171e8a0282459dfbe06ceeff50b500298d4dab2408da41 SHA512 7ba6e25932ddc1fd466396957779165b27dca693b347b459da8e774cda05e69dd845f11ae641dbcb3743d047688a2f991edb89aa296cbf3aeb3af5f06869daaf
diff --git a/dev-python/pyode/metadata.xml b/dev-python/pyode/metadata.xml
new file mode 100644
index 000000000000..d379d56a54fc
--- /dev/null
+++ b/dev-python/pyode/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">pyode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyode/pyode-1.2.0_p20100322-r1.ebuild b/dev-python/pyode/pyode-1.2.0_p20100322-r1.ebuild
new file mode 100644
index 000000000000..ec445e803c76
--- /dev/null
+++ b/dev-python/pyode/pyode-1.2.0_p20100322-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+inherit distutils-r1
+
+MY_P="${P/pyode/PyODE}"
+SNAPSHOT_DATE="2010-03-22" # This is a snapshot
+
+DESCRIPTION="Python bindings to the ODE physics engine"
+HOMEPAGE="http://pyode.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/PyODE-snapshot-${SNAPSHOT_DATE}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=">=dev-games/ode-0.7
+ >=dev-python/pyrex-0.9.4.1[${PYTHON_USEDEP}]"
+DEPEND=${RDEPEND}
+
+S=${WORKDIR}/PyODE-snapshot-${SNAPSHOT_DATE}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ # The build system doesnt error if it fails to build
+ # the ode library so we need our own sanity check
+ [[ -n $(find "${D}" -name ode.so) ]] || die "ode.so is missing"
+
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}