summaryrefslogtreecommitdiff
path: root/dev-python/pyocr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /dev-python/pyocr
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'dev-python/pyocr')
-rw-r--r--dev-python/pyocr/Manifest4
-rw-r--r--dev-python/pyocr/metadata.xml3
-rw-r--r--dev-python/pyocr/pyocr-0.8.ebuild30
3 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/pyocr/Manifest b/dev-python/pyocr/Manifest
index ede42fbc24e4..84437576318c 100644
--- a/dev-python/pyocr/Manifest
+++ b/dev-python/pyocr/Manifest
@@ -1,3 +1,5 @@
DIST pyocr-0.7.2.tar.gz 65376 BLAKE2B 065084c19c7722e590c5f20abe5248b2be0c76dab864b4a4e2c457770ff61dec84df7254f19e4926753f39a5d1ed0618ed87827b85773ab96a51e3f7798c656f SHA512 002c3302ed20e19e06dc6fd995ce30150fb95650824df9e0a3d6b2bdcb4c0ae3f2295342c2df44e0d5a9c9bbf5432f47a9d7562e4866b87738ac3436a8c0dec9
+DIST pyocr-0.8.tar.gz 65454 BLAKE2B 881353eebce22cf316cd4375cc8971e740a9a463216a5b49c07c7813340cfa1a9bdd869b84b4c26566deab1551884179ae2fe0184dec73880b716118367803cd SHA512 c8d811001b460a9004a80fbf570df3fe9a6af11e8ca0e90f23e5f3be54f6a54d859f4ad3db126a5216ea557ecb38ebd5dbece91810df2bf3e95f514c39649bce
EBUILD pyocr-0.7.2.ebuild 719 BLAKE2B e10434699e78349ac1b48d5dbfff2de8f3c80ebb6e21b62657091332d6241e75b82a801a39a7659bc0098756ed0ea0738fad4241ce1695ca59d23464219fe01c SHA512 4725dc3b876070863a4caafd74218b38a46c424bf11c23b78306cd88856263ee3c45ffcf05fd4da823fadcfc66d704cbf53f1ce42142d0a59a29c79c7ea9ee7b
-MISC metadata.xml 1052 BLAKE2B 6899cd20551d02aa5f94143d47b5e32133066b235a5c12feea9f7438648372fa3a6119e6e3db8e42d27a81995ea08b60d9e51585d613e87a9c1067b931c524b8 SHA512 2cdec5344e8bce0cd8736a403b7c7be94eb56cf44ec1ba35252ca4f0baff1e912933151f1e22267c3b01ae7cb6960523e54b5b818324d6d186d3fcf5aea3ac1f
+EBUILD pyocr-0.8.ebuild 804 BLAKE2B b0f48b6c0d42f8626d06730fbd5400b9bb3d4b5fc16683b8e99ed5f73f9ef1c4cd1af8ecccd820d43ef5036369c487e9d17e6fa4905bc6136ed597e2961c7778 SHA512 cef145c69319ff438fb778ae7a264e5582e70393df33d39a3a5e14ea082323ac8b8a18d6775ef00ff042ef39bc92a612405f77d4287984797e7460ccf2f4e8c5
+MISC metadata.xml 1131 BLAKE2B a2d57e8b74c24b6c81b075b5392492f6681c9663cbfa9908ef4549f87b9b5746b7ab54bdfd2407f5842664c4a1f26a263fcc61007f750a613dff67ed8c02765e SHA512 9d93a3feec156473a8b4e9351fe5a5a1fd700eb49757a09557ff61f825438d15810fe1107a42e78e2aed5bfcb39a38d10f3773b544ab9170070852868601237b
diff --git a/dev-python/pyocr/metadata.xml b/dev-python/pyocr/metadata.xml
index f260241d12b3..10e017f97684 100644
--- a/dev-python/pyocr/metadata.xml
+++ b/dev-python/pyocr/metadata.xml
@@ -5,6 +5,9 @@
<email>voyageur@gentoo.org</email>
<name>Bernard Cafarelli</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
<longdescription lang="en">
Pyocr is an optical character recognition (OCR) tool wrapper for python. That is, it helps using OCR tools from a Python program.
diff --git a/dev-python/pyocr/pyocr-0.8.ebuild b/dev-python/pyocr/pyocr-0.8.ebuild
new file mode 100644
index 000000000000..3be5b79808ce
--- /dev/null
+++ b/dev-python/pyocr/pyocr-0.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="An optical character recognition (OCR) tool wrapper"
+HOMEPAGE="https://gitlab.gnome.org/World/OpenPaperwork/pyocr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cuneiform +tesseract"
+REQUIRED_USE="|| ( cuneiform tesseract )"
+
+RDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]"
+
+# (tests apparently do not require any backend installed)
+distutils_enable_tests unittest
+
+RDEPEND+="
+ cuneiform? ( app-text/cuneiform )
+ tesseract? ( app-text/tesseract )"