summaryrefslogtreecommitdiff
path: root/dev-python/pymountboot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pymountboot
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pymountboot')
-rw-r--r--dev-python/pymountboot/Manifest4
-rw-r--r--dev-python/pymountboot/metadata.xml16
-rw-r--r--dev-python/pymountboot/pymountboot-0.2.2.ebuild24
-rw-r--r--dev-python/pymountboot/pymountboot-9999.ebuild34
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/pymountboot/Manifest b/dev-python/pymountboot/Manifest
new file mode 100644
index 000000000000..f6e952b0d0bd
--- /dev/null
+++ b/dev-python/pymountboot/Manifest
@@ -0,0 +1,4 @@
+DIST pymountboot-0.2.2.tar.bz2 4098 BLAKE2B bbfbe631313189e6aef684ff29e73fcf2dcbbb998528103afe9c89e517e5a6c13bf6e05ced7c2eb05f668e0cc269212618b648043b65fb95da2e1b46c37476ac SHA512 bb6ec0772300b2edf9864a09ff64f67ad99f0cd29b009793e1b2a590be48146640c927b5772023d27e68fc2fba51652a55ab66d1cf875dd9b4134f043ac353c9
+EBUILD pymountboot-0.2.2.ebuild 600 BLAKE2B 898387af21a770c019ab471d2bd87f76324347f9b5c143cba00bf83fd83909bb308cd9458fa9898f0b624ccbe6a79c3fa517931da711bd0bbf79ced1d2065e9c SHA512 540f0ddae0944f8663ca802b530b23718c08cb0839ce0c0759ece91ea8f1d265f7929a3b8526ad2c92ca260ca83b723618efa2845ed2a9bc486386c027be3bf5
+EBUILD pymountboot-9999.ebuild 725 BLAKE2B 7d269d71fca86676a1dd78a33605ddcee852ac3ad28fd6b126c311f12334833fced52715e7db8bb57031bc8e818a609e5cc895dcd652592ab4eaa1c54a4748cb SHA512 e34f603432578895bfa4380aca112d5d76551acf6fcac3c7cf3aa39ec001958211351f53dea5c41b886382db2b572d9b9ec1d163599b3a9279c668cb43c7f4a7
+MISC metadata.xml 539 BLAKE2B 0ab0699ff77f99bb28bfc66ddfad742f877f256a597305b3ce4d4a462c865696a7c466e32e0f68eccb138d367c5d360880372a5816683fb49d1063a5c55d9249 SHA512 d95f758cbce79b166abc9cf68c5605e03a4b5f168a25e46016c812e667bed8ce40a146beeb02ea236890f081154e2239e87386ccb37aa29acbb134fdf7704756
diff --git a/dev-python/pymountboot/metadata.xml b/dev-python/pymountboot/metadata.xml
new file mode 100644
index 000000000000..66d4e59e6ec1
--- /dev/null
+++ b/dev-python/pymountboot/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://bitbucket.org/mgorny/pymountboot/issues/</bugs-to>
+ <remote-id type="bitbucket">mgorny/pymountboot</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pymountboot/pymountboot-0.2.2.ebuild b/dev-python/pymountboot/pymountboot-0.2.2.ebuild
new file mode 100644
index 000000000000..6390c3678064
--- /dev/null
+++ b/dev-python/pymountboot/pymountboot-0.2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python extension module to (re)mount /boot"
+HOMEPAGE="https://bitbucket.org/mgorny/pymountboot/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/util-linux-2.20"
+DEPEND="${RDEPEND}"
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
diff --git a/dev-python/pymountboot/pymountboot-9999.ebuild b/dev-python/pymountboot/pymountboot-9999.ebuild
new file mode 100644
index 000000000000..6b4362ffab04
--- /dev/null
+++ b/dev-python/pymountboot/pymountboot-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+#if LIVE
+EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}.git"
+inherit git-r3
+#endif
+
+DESCRIPTION="Python extension module to (re)mount /boot"
+HOMEPAGE="https://bitbucket.org/mgorny/pymountboot/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/util-linux-2.20"
+DEPEND="${RDEPEND}"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}