summaryrefslogtreecommitdiff
path: root/dev-python/pymountboot/pymountboot-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pymountboot/pymountboot-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pymountboot/pymountboot-9999.ebuild')
-rw-r--r--dev-python/pymountboot/pymountboot-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pymountboot/pymountboot-9999.ebuild b/dev-python/pymountboot/pymountboot-9999.ebuild
new file mode 100644
index 000000000000..6b4362ffab04
--- /dev/null
+++ b/dev-python/pymountboot/pymountboot-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+#if LIVE
+EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}.git"
+inherit git-r3
+#endif
+
+DESCRIPTION="Python extension module to (re)mount /boot"
+HOMEPAGE="https://bitbucket.org/mgorny/pymountboot/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/util-linux-2.20"
+DEPEND="${RDEPEND}"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}