summaryrefslogtreecommitdiff
path: root/dev-python/pymongo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /dev-python/pymongo
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'dev-python/pymongo')
-rw-r--r--dev-python/pymongo/Manifest2
-rw-r--r--dev-python/pymongo/pymongo-3.10.1.ebuild28
2 files changed, 14 insertions, 16 deletions
diff --git a/dev-python/pymongo/Manifest b/dev-python/pymongo/Manifest
index fe1df0c814ca..4d18b67b434d 100644
--- a/dev-python/pymongo/Manifest
+++ b/dev-python/pymongo/Manifest
@@ -1,3 +1,3 @@
DIST pymongo-3.10.1.tar.gz 715892 BLAKE2B df1f8ae34366ea9de633be7e1ca103a2bc704a18a9b23cb1fbdbc8d116e939d4d5462e18a076149d93dcb8ada9f4737ed2d61b08803b546dce89dca4b2416689 SHA512 5a73ac17ef6f6783a573facd90879dbefa0c95d69123bc67c1a6af0987cb5786f637b8fa81a6810387acc34829a4cde33b848ac0f7b08f7d07faa90a8e13b595
-EBUILD pymongo-3.10.1.ebuild 2751 BLAKE2B 62898d50854f0f43c36a0dc6889cfcc8dfa5d734287294a3d9ec66019ab7184a37bbb27e3bac9d53a4a83dd9190049f880d48d30ded307bfd06be19df0019ef2 SHA512 abf389a07a0784900e278f06ceee2366618a421dcf79f9d621f05a539463150ac1c0c4000731aa3a74e99153afd3587ff7b877d734187aecd3bd155ddb6f89c6
+EBUILD pymongo-3.10.1.ebuild 2854 BLAKE2B 70c1f06d278465491dab6c124629c0ab7a2310e5521b8357a57e4db6bfe3c4347c55744f7c205256088b04b3f65402482b50292ac73d4ea7335bfff80e91fc65 SHA512 0b4185f73dbd81b07ae04e54cdcccba08dfeac591c3780e8a1572de7d0fe2971dd482492372525ee6d324fa38804847cead63c9ef2748251084163b71d900b41
MISC metadata.xml 672 BLAKE2B 48cf6ce2f03ec2865a99fd033455a1b0a53cf9e55240ab6e993483929a6dd93661afcea7fa255095b66536f0a8cc05b5c4e6a12bd044547a5cf190559a9e480f SHA512 89b8a3551a5b0bd495bc98ac2f9324daeb3f3d81d0f6b991e5537e02c7b369201f9692be5acbe228ddcd3581002a39ac777ea5fc136957e9ccb9683f205e38ea
diff --git a/dev-python/pymongo/pymongo-3.10.1.ebuild b/dev-python/pymongo/pymongo-3.10.1.ebuild
index be2abc3cb002..e29624b5f6c5 100644
--- a/dev-python/pymongo/pymongo-3.10.1.ebuild
+++ b/dev-python/pymongo/pymongo-3.10.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_COMPAT=( python2_7 python3_{6..9} )
inherit check-reqs distutils-r1
DESCRIPTION="Python driver for MongoDB"
@@ -14,14 +14,12 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 arm64 ~hppa x86"
IUSE="doc kerberos test"
-
RESTRICT="!test? ( test )"
RDEPEND="
kerberos? ( dev-python/pykerberos[${PYTHON_USEDEP}] )
"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+BDEPEND="
test? (
>=dev-db/mongodb-2.6.0
dev-python/nose[${PYTHON_USEDEP}]
@@ -29,6 +27,8 @@ DEPEND="${RDEPEND}
"
DISTUTILS_IN_SOURCE_BUILD=1
+distutils_enable_sphinx doc
+
reqcheck() {
if use test; then
# During the tests, database size reaches 1.5G.
@@ -46,11 +46,15 @@ pkg_setup() {
reqcheck pkg_setup
}
-python_compile_all() {
- if use doc; then
- mkdir html || die
- sphinx-build doc html || die
- fi
+src_prepare() {
+ # network-sandbox probably
+ rm test/test_srv_polling.py || die
+ sed -e 's:test_connection_timeout_ms_propagates_to_DNS_resolver:_&:' \
+ -i test/test_client.py || die
+ # relies on exact exception message
+ sed -e 's:abstract methods:abstract:' \
+ -i test/test_custom_types.py || die
+ distutils-r1_src_prepare
}
python_test() {
@@ -111,9 +115,3 @@ python_test() {
rm -rf "${dbpath}" || die
}
-
-python_install_all() {
- use doc && local HTML_DOCS=( html/. )
-
- distutils-r1_python_install_all
-}