summaryrefslogtreecommitdiff
path: root/dev-python/pymongo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-19 07:57:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-19 07:57:57 +0100
commit27f7ac2204449d9fc2137f442522b4fb10327d90 (patch)
treee0fa5de044037be9ff62dcb6bcc8dbeca087767d /dev-python/pymongo
parent84a400be40cf32d9e536ae34ebf14ad06ad6b8d6 (diff)
gentoo auto-resync : 19:10:2022 - 07:57:56
Diffstat (limited to 'dev-python/pymongo')
-rw-r--r--dev-python/pymongo/Manifest2
-rw-r--r--dev-python/pymongo/pymongo-4.3.2.ebuild122
2 files changed, 124 insertions, 0 deletions
diff --git a/dev-python/pymongo/Manifest b/dev-python/pymongo/Manifest
index 7919c1f8985c..7a4dbd36fc8b 100644
--- a/dev-python/pymongo/Manifest
+++ b/dev-python/pymongo/Manifest
@@ -1,5 +1,7 @@
DIST mongo-python-driver-4.1.1.tar.gz 1070349 BLAKE2B 9b792343a22c4b0c625376e6f3d10e9c1a88442b63ff2638c29588a26755006507189bf40a8dad96d7f8e4f997efc153c8616826b58114aba32442c05b80ca60 SHA512 b01eb6bc4c39a25cae8350bdc2f37dd5d78da38a6eddbd8a26f91cb6ee067f7b4b1d97eb603defca16e05abc992b8f11b2e3558f9697c99697b3e876838de737
DIST mongo-python-driver-4.2.0.gh.tar.gz 1136734 BLAKE2B b3e2d86780c2874656f94ba3071317c0b9190418274c163135a260cad3f5672b9390aa738d0cf1aaff47412827620706e67c5c990910a5ea232aaacda0758dea SHA512 4439149c35f897a61109b26f5e4c613682ca59727495377a3bbb49f9ff22273cd5a73f58fb55080d07c9403310d4ada59d3a5969d0f76f2f4d1081422fe2dfec
+DIST mongo-python-driver-4.3.2.gh.tar.gz 1154135 BLAKE2B f2a560dc9829b6b26a78c032a3978fff93935b78aa20a088a080bdd607d951a57434473d698d4cabc1ca0a767cdb75352e0e25d9cfd77389d43062768409625c SHA512 f35dd2fc54e806bb7f91d982f29ebdee8ef12a8629b415b2472e3f99d60ad9e3153cd54e6e7369124c2b31c27df636c2a0fa72f937aeafb60c64c90728d7b03b
EBUILD pymongo-4.1.1.ebuild 2762 BLAKE2B 55e8e7d00cb2cc710cfe9577e18641964d74e670f89e123ed07a83bee69e2a7292eaae5eea8e75a6201efac6068648fbd831a54d74f430d03bf2088ae65fbc91 SHA512 c6e62e89a90ed45763cb0f679bae97187062cdcf4d22bd199f2ed1d24617648ff383cf8e3401add6b188ca4526ad1020b25951c6381b833ab98115bc3326027b
EBUILD pymongo-4.2.0.ebuild 2772 BLAKE2B 8d9de2ae30201c86a1406699f881e1320bf7055f875f58db1f09972ae3f3deadde57ae5c1215cc9786f21f4edb5ab5ea561f88428992c50b56d7fc011dc36257 SHA512 2a533fc3fee6369227f08c3a22bd71628a19e89f2d579f303050bc19cc69d16613a301b2ec704a33df6f34df7d81ad1f6f2defa4e3f8aa114d33716f3ec434e8
+EBUILD pymongo-4.3.2.ebuild 2821 BLAKE2B c9c6a53de6d046d6f5c79d9fed77e0decdc620ed1adb62074b9dba51138560ae593e5e4e52f20e4648e6577052f0ef9d5e62188b8ba9680d6b2b625e268de87f SHA512 9cc9764b38b6eec6cc4af6fe89f239fd4e38fc97ea0769aa0afa9f515f502c981499ca1ab597457e9f31bb7a9e0622b0291f48c1f59bfb61cd53d21e55e3f720
MISC metadata.xml 673 BLAKE2B fb66f76592841f2647a94e24e07fafa8be2bc31583bac35dc3933a3feeea87f0c4105ab6b480bce5f2b8aeced8c113c8a3ce9714b22ff909f92eccceffa8f9a9 SHA512 9e758aa60153da583ed21bdf6addd001c560894fc6d429217405e7dfbdc673a9e22bc5a41afcc1281f7613ae1059c0824a7bba246006aa66c6eced75ab975e51
diff --git a/dev-python/pymongo/pymongo-4.3.2.ebuild b/dev-python/pymongo/pymongo-4.3.2.ebuild
new file mode 100644
index 000000000000..1f6df3375c8e
--- /dev/null
+++ b/dev-python/pymongo/pymongo-4.3.2.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit check-reqs distutils-r1
+
+MY_P=mongo-python-driver-${PV}
+DESCRIPTION="Python driver for MongoDB"
+HOMEPAGE="
+ https://github.com/mongodb/mongo-python-driver/
+ https://pypi.org/project/pymongo/
+"
+SRC_URI="
+ https://github.com/mongodb/mongo-python-driver/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~riscv ~x86"
+IUSE="doc kerberos"
+
+RDEPEND="
+ <dev-python/dnspython-3.0.0[${PYTHON_USEDEP}]
+ kerberos? ( dev-python/pykerberos[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ >=dev-db/mongodb-2.6.0
+ )
+"
+
+distutils_enable_sphinx doc
+distutils_enable_tests unittest
+
+reqcheck() {
+ if use test; then
+ # During the tests, database size reaches 1.5G.
+ local CHECKREQS_DISK_BUILD=1536M
+
+ check-reqs_${1}
+ fi
+}
+
+pkg_pretend() {
+ reqcheck pkg_pretend
+}
+
+pkg_setup() {
+ reqcheck pkg_setup
+}
+
+src_prepare() {
+ # network-sandbox
+ rm test/test_srv_polling.py || die
+ sed -e 's:test_connection_timeout_ms_propagates_to_DNS_resolver:_&:' \
+ -e 's:test_service_name_from_kwargs:_&:' \
+ -e 's:test_srv_max_hosts_kwarg:_&:' \
+ -i test/test_client.py || die
+ sed -e '/SRV_SCHEME/s:_HAVE_DNSPYTHON:False:' \
+ -i test/test_uri_spec.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # Yes, we need TCP/IP for that...
+ local DB_IP=127.0.0.1
+ local DB_PORT=27000
+
+ export DB_IP DB_PORT
+
+ local dbpath=${TMPDIR}/mongo.db
+ local logpath=${TMPDIR}/mongod.log
+
+ # Now, the hard part: we need to find a free port for mongod.
+ # We're just trying to run it random port numbers and check the log
+ # for bind errors. It shall be noted that 'mongod --fork' does not
+ # return failure when it fails to bind.
+
+ mkdir -p "${dbpath}" || die
+ while true; do
+ ebegin "Trying to start mongod on port ${DB_PORT}"
+
+ LC_ALL=C \
+ mongod --dbpath "${dbpath}" --nojournal \
+ --bind_ip ${DB_IP} --port ${DB_PORT} \
+ --unixSocketPrefix "${TMPDIR}" \
+ --logpath "${logpath}" --fork \
+ && sleep 2
+
+ # Now we need to check if the server actually started...
+ if [[ ${?} -eq 0 && -S "${TMPDIR}"/mongodb-${DB_PORT}.sock ]]; then
+ # yay!
+ eend 0
+ break
+ elif grep -q 'Address already in use' "${logpath}"; then
+ # ay, someone took our port!
+ eend 1
+ : $(( DB_PORT += 1 ))
+ continue
+ else
+ eend 1
+ eerror "Unable to start mongod for tests. See the server log:"
+ eerror " ${logpath}"
+ die "Unable to start mongod for tests."
+ fi
+ done
+
+ local failed
+ DB_PORT2=$(( DB_PORT + 1 )) DB_PORT3=$(( DB_PORT + 2 )) esetup.py test || failed=1
+
+ mongod --dbpath "${dbpath}" --shutdown || die
+
+ [[ ${failed} ]] && die "Tests fail with ${EPYTHON}"
+
+ rm -rf "${dbpath}" || die
+}