summaryrefslogtreecommitdiff
path: root/dev-python/pymilter/pymilter-1.0.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/pymilter/pymilter-1.0.4-r1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/pymilter/pymilter-1.0.4-r1.ebuild')
-rw-r--r--dev-python/pymilter/pymilter-1.0.4-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/pymilter/pymilter-1.0.4-r1.ebuild b/dev-python/pymilter/pymilter-1.0.4-r1.ebuild
index ab1081c7100a..5a706a8fdf00 100644
--- a/dev-python/pymilter/pymilter-1.0.4-r1.ebuild
+++ b/dev-python/pymilter/pymilter-1.0.4-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit distutils-r1
@@ -13,9 +13,11 @@ SRC_URI="https://github.com/sdgathman/${PN}/archive/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
-DEPEND="|| ( mail-filter/libmilter mail-mta/sendmail )"
+DEPEND="|| ( mail-filter/libmilter mail-mta/sendmail )
+ test? ( $(python_gen_impl_dep sqlite) )"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}-${P}"