summaryrefslogtreecommitdiff
path: root/dev-python/pylru
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/pylru
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/pylru')
-rw-r--r--dev-python/pylru/Manifest2
-rw-r--r--dev-python/pylru/pylru-1.2.0.ebuild12
2 files changed, 8 insertions, 6 deletions
diff --git a/dev-python/pylru/Manifest b/dev-python/pylru/Manifest
index ccea7073286b..acfeb5f96f16 100644
--- a/dev-python/pylru/Manifest
+++ b/dev-python/pylru/Manifest
@@ -1,3 +1,3 @@
DIST pylru-1.2.0.tar.gz 18533 BLAKE2B 6cebc3ecc91050bdf3c8f2721a7ee1768fb48692567eb2e8603e0d28fbfd01634087bf8fda0c0c3f8c9af377195623d2689f9eb59a3ad781ccfc5f58b362a734 SHA512 d4b247cb3740c2f94f4f41bd9affbb87db4e2ec8ff566978d130d08fee9df6109c13b64f22536903bf8be3ea60d4b105dd969d1156a279115b6bfedb817cdbf5
-EBUILD pylru-1.2.0.ebuild 401 BLAKE2B fbd9f6a1c0f32143da6f599863fbb5561f7114e420e586200456493fa286bbb1e050a1d03759101d92e0a631f15ac4549b58e4a88651aa618ab476ded5934bcf SHA512 db37e0ed075058d40d82e51d5e30a317525f4658967c56bea5c93854dfd35f6d0f6483364a32f2c49a6f1d52e334e6be98225517b41f369b48686cb86da066ee
+EBUILD pylru-1.2.0.ebuild 461 BLAKE2B add68c55187cd6c1c53b4ed9f527befbaf23a6bcea2964b8f92e7da298f01fa905c2196b24082947d308287c4fb09730a92864864471bdefa9e2ff2d13d24e8a SHA512 5e442e006bb8c9f2d954ad20c9fce8c72624cfa25a5b9362f782a97180b60cee160ab0b3f5885652bb349f8defa7e3ebc107ae46a1e0a61cba56b0386a426957
MISC metadata.xml 369 BLAKE2B 4689e535bc1ad7110ae6ef173aa013e78590a3b66a59d324e476f08fead674c041653abe435ef27c8fb46b52a0cc0c999e36d7ae66875208877bcf8ffbe575c1 SHA512 2782acfafc75433a7207a9d698a6e067119089d5c2d3832228aa2d00637bb8d85372f167c588a6271a3c8c466a60749d1079706181ab1b0ac53b6d9590d91284
diff --git a/dev-python/pylru/pylru-1.2.0.ebuild b/dev-python/pylru/pylru-1.2.0.ebuild
index 73f3e86bb7fa..f22b1b0e9eb6 100644
--- a/dev-python/pylru/pylru-1.2.0.ebuild
+++ b/dev-python/pylru/pylru-1.2.0.ebuild
@@ -1,18 +1,20 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
DESCRIPTION="A least recently used (LRU) cache for Python"
HOMEPAGE="https://github.com/jlhutch/pylru"
-LICENSE="GPL-2"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64"
-BDEPEND=""
-RDEPEND=""
+python_test() {
+ "${EPYTHON}" test.py || die "tests failed under ${EPYTHON}"
+}