summaryrefslogtreecommitdiff
path: root/dev-python/pylru
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /dev-python/pylru
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'dev-python/pylru')
-rw-r--r--dev-python/pylru/Manifest3
-rw-r--r--dev-python/pylru/metadata.xml16
-rw-r--r--dev-python/pylru/pylru-1.2.0.ebuild18
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pylru/Manifest b/dev-python/pylru/Manifest
new file mode 100644
index 000000000000..36ec1526e17e
--- /dev/null
+++ b/dev-python/pylru/Manifest
@@ -0,0 +1,3 @@
+DIST pylru-1.2.0.tar.gz 18533 BLAKE2B 6cebc3ecc91050bdf3c8f2721a7ee1768fb48692567eb2e8603e0d28fbfd01634087bf8fda0c0c3f8c9af377195623d2689f9eb59a3ad781ccfc5f58b362a734 SHA512 d4b247cb3740c2f94f4f41bd9affbb87db4e2ec8ff566978d130d08fee9df6109c13b64f22536903bf8be3ea60d4b105dd969d1156a279115b6bfedb817cdbf5
+EBUILD pylru-1.2.0.ebuild 405 BLAKE2B 450ae1ae0ce9dad0d18624080fcd06cfb550dbf4c8e076847b1fec634631d1acbc8283a61f7cf39386d69fdadde983339acd129ae47051aac7bab8736f045de8 SHA512 68f0194e5e0e8c4d289df95af8699db1b09b0edf4289c0349d13e595c50251a0a39e5ecce752cfd8124a6ee415e60dd45828e2f50b8bb093b37a60fe370351c8
+MISC metadata.xml 470 BLAKE2B 32b64d263398df170ccc09f9637f9391fb9dc5ad5e63596e44ab915eda77fcbf4ba9e6f19657f25cb362451d0bd03e6caa11fe7388e258ad3941826c1b7d7977 SHA512 a05cdfa30ad11c843fe5cdeaac17983fd90a28ef6a4a942b4817aaf960d93e544610b523a1f1c117312fa551bc9b5b421ca510bb4fdbff2f5acfa983b4ab084a
diff --git a/dev-python/pylru/metadata.xml b/dev-python/pylru/metadata.xml
new file mode 100644
index 000000000000..c76e89ae9f66
--- /dev/null
+++ b/dev-python/pylru/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pylru</remote-id>
+ <remote-id type="github">jlhutch/pylru</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pylru/pylru-1.2.0.ebuild b/dev-python/pylru/pylru-1.2.0.ebuild
new file mode 100644
index 000000000000..bcc8466604aa
--- /dev/null
+++ b/dev-python/pylru/pylru-1.2.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A least recently used (LRU) cache for Python"
+HOMEPAGE="https://github.com/jlhutch/pylru"
+LICENSE="GPL-2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+BDEPEND=""
+RDEPEND=""