summaryrefslogtreecommitdiff
path: root/dev-python/pylru/pylru-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/pylru/pylru-1.2.1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/pylru/pylru-1.2.1.ebuild')
-rw-r--r--dev-python/pylru/pylru-1.2.1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/pylru/pylru-1.2.1.ebuild b/dev-python/pylru/pylru-1.2.1.ebuild
new file mode 100644
index 000000000000..a305db0736a8
--- /dev/null
+++ b/dev-python/pylru/pylru-1.2.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A least recently used (LRU) cache for Python"
+HOMEPAGE="https://github.com/jlhutch/pylru"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+python_test() {
+ "${EPYTHON}" test.py || die "tests failed under ${EPYTHON}"
+}