summaryrefslogtreecommitdiff
path: root/dev-python/pylint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
commitf616ce4660c92a3fcb4f05663c2ab47c9defa0c3 (patch)
tree66ba5228853030737ae2dd9c9894b96266213246 /dev-python/pylint
parent1bfb8c3d7e00e7ff828008510f5a7568c81d8889 (diff)
gentoo auto-resync : 30:11:2022 - 01:22:10
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest2
-rw-r--r--dev-python/pylint/pylint-2.15.7.ebuild85
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 1dc686537658..2ee7146a6881 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,5 +1,7 @@
DIST pylint-2.15.5.gh.tar.gz 1312932 BLAKE2B b8de4e16122ba0bea4cfd9ce3ec4a12abf5e408d7f9d60875eaac781a962c0d01af7691b3c110f2b895bcb7c2d47e0f868d5d52171594aaaecb53ea045a179b9 SHA512 a6e123ab516ef12be0651dbe144814d9f3f9263d61c259d79e9505ee3b4011b33e302281067aa5bacd504fa079f3a7aaceee4d1f9aad127bec8ebeddfeb2afbe
DIST pylint-2.15.6.gh.tar.gz 1314945 BLAKE2B c084f419dbefb3346e75af204e576fb4b720f15f865ed8ab3e7bbd017edc3ad78c5c2f28ca26600bc40a79d8bcffc20bcde51144257374c8fbd8c63580d85192 SHA512 6e44c288dd243cb1cd8faec645edc9a60fa3fe852f189d2527c4382a415f16b612808f9d15072f5e22c4106a4ecc2f5746bea898ac76c9481a4d1eb8b30fd778
+DIST pylint-2.15.7.gh.tar.gz 1317019 BLAKE2B 46a163b41b2675efe24e04ca052ac2e9c88d075b551bb83c7d7369dd3b53c54d1f7ded12ff99ea0d2f4651e315e760fabb89149c1cc5c91676a2da2444d07a9d SHA512 6e6b544babc5c56f2e59fea7e907ea88f9d6456cebaf50ebdfe935edcc70f8b6b0d52665df7f7a2fec11578a7d8b7aea32c09aa3729aad38e9375df19ea7709f
EBUILD pylint-2.15.5.ebuild 2464 BLAKE2B 2bf3f42db574d61e67fa83910df8af134b4f8b32b831d0f521ef624009ebbef8308bed9acdaaaab02b5720412a1e618facf52e7bec3611eb71f5084ce382abfa SHA512 268783cbec0e35d9919a33e8b60fc4403b256b068eb2f2e124608ef3bcada544317daa16b99e43e628bb302c0e95400999b4e29e6e985b9782a473e577d3ccfc
EBUILD pylint-2.15.6.ebuild 2472 BLAKE2B 19016922b61bf37c353823a2b08c3805b83d640c570a528fc3b41681d2aa4eb1f12b488092c241fded6fcfc050bbff82d9f805f5e6cd628f8aae76b4d67c71b5 SHA512 7108609cb88793acada884eb5ebebba6080d3afbf230887935c0b09e5a7d78b6cbf38a9b812161f7afee12aa9f54d3e5a89d0c65d4f081a8801c5b1177831761
+EBUILD pylint-2.15.7.ebuild 2472 BLAKE2B 794ee45fef5be1f3c7ced1e323b03b45cc7ebe7242ee7fa0bac3953e88bc264fef3e94d89629c98fe9a140bec4aef5fc26b49881c71409bd33220f5f5d0a1b28 SHA512 cfd469cf989c17bbbbc20e2487cfb0ed1227bec204f8d5823b9f5a1e888c401c6932239ceb8630ae7145457569e27da0a669901caa344c20e1a18f6889193353
MISC metadata.xml 1100 BLAKE2B 97ec6bd2f6cf487afb93136e9ee58d0d5f8ad37e2ded456ed4f196e73fd37cddead2462d3592b44ca1a6c3722b1f194905238299f0c066945d1e22bdb18acc9b SHA512 0418d987879446fd76fe9b7fc4ee8b1c3c0d9bbab1d1fc3eb66eada0bc52f6b6480cf9852dc3a18b1915d2093642b9c87f24207e89b34d3e48c29a282a3ba979
diff --git a/dev-python/pylint/pylint-2.15.7.ebuild b/dev-python/pylint/pylint-2.15.7.ebuild
new file mode 100644
index 000000000000..9af626928fd1
--- /dev/null
+++ b/dev-python/pylint/pylint-2.15.7.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ https://pypi.org/project/pylint/
+ https://github.com/PyCQA/pylint/
+"
+SRC_URI="
+ https://github.com/pycqa/pylint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+# Make sure to check https://github.com/PyCQA/pylint/blob/main/pyproject.toml#L34 on bumps
+# Adjust dep bounds!
+RDEPEND="
+ <dev-python/astroid-2.14[${PYTHON_USEDEP}]
+ >=dev-python/astroid-2.12.13[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.2[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf pylint || die
+
+ local EPYTEST_DESELECT=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+
+ # TODO
+ 'tests/test_functional.py::test_functional[forgotten_debug_statement_py37]'
+ 'tests/test_functional.py::test_functional[dataclass_with_field]'
+ 'tests/test_functional.py::test_functional[no_name_in_module]'
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_error_msg
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_info_msg
+ tests/config/pylint_config/test_run_pylint_config.py::test_invocation_of_pylint_config
+
+ # apparently fragile, needs unpickleable plugin
+ tests/test_check_parallel.py::TestCheckParallelFramework::test_linter_with_unpickleable_plugins_is_pickleable
+ )
+ epytest
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}