summaryrefslogtreecommitdiff
path: root/dev-python/pylint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-07 11:57:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-07 11:57:01 +0000
commitb3fef92e618039dc93153a93176184a49606c74a (patch)
treead9ab32cccd1125450feb872dd493ae07b6f4ffd /dev-python/pylint
parent32f67cc4163d5c6e094345e920ada52367df5f5f (diff)
gentoo auto-resync : 07:03:2023 - 11:57:00
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest2
-rw-r--r--dev-python/pylint/pylint-2.16.4.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index a66a3dd6bb16..aa49662279bb 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,5 +1,7 @@
DIST pylint-2.16.2.gh.tar.gz 1382056 BLAKE2B 35c4c07fb750c884d62c9ec563e5133654b9ecef41d320976214a1cae25cd28f1681dcc3053cc358276cfc3cc76df770fbb2f7691e387bb07b6ff803f4a21d0b SHA512 36a76fa7a5ae9c4fead66a0964dd40963c51db8225ec112b0557d04ddf2f89ea9649e390c005ccc35341b2ac5f69f6ccf17652d08cba223fdcd36ccf433659bb
DIST pylint-2.16.3.gh.tar.gz 1382318 BLAKE2B 67e2e7b6facde79268267e44081e1b71e391654b959e39c0d3893e1d6ffd0a79423d3c9663e0aeaadd4321669e17799af4351bcbd2cbd51518ec5f1b4db940ab SHA512 3918c15bbf94de7a4150652dc1fc8cc2929255470198d52bcbfe1205017192e748a852aa0174bf864165ce5e9eac70e4f1a23ca3275fea3f584216c32b224b61
+DIST pylint-2.16.4.gh.tar.gz 1382902 BLAKE2B 515078d2677e4374041de563ec2a98cf877848a0f1042c26f331a21335e030e15a3d6ba4eb539c18cc3835fc9505270c540b9c64f61c037759171deec41f5f10 SHA512 144a7b048340c65082f02f34d511e0066019ac08d28eb5f8c114086b66a471355631355b24f291916fa2e6b9db8e0e69a4649ad9ce036bbf2418fd6a73089fc5
EBUILD pylint-2.16.2.ebuild 2561 BLAKE2B c39ddf3ca56145e06068f9594fd6cd891863b197327753d8e28fe571441ee4b67e0df6b2497cfea7a44ab03a0bb70f3ebf2e7d724383ffdbde99d43c584ccb56 SHA512 c933fe4fbbeef2ff7bd1073a3ab36009c9b4c5d35e969a39d23d3e2c658b4a79bee03614a22202b38fbfbaac4c0151fec4b0885901500bf834564f492bf21736
EBUILD pylint-2.16.3.ebuild 2569 BLAKE2B 2e735782c5ad37ad13b61959b1ed9caac17290935f34cde22e31f4cea9ed6f6a71b4e64875ef65a2d8913a80c3d6a6b5841e5f1c278af0559100c0c53a1bc04b SHA512 6b3c8a7b0669290b1af9c418af4cd96151170e44b597b47680ce3d854817df4b350b903eb77e0ab60b090580588af96d6a148452b0c16a5a0e0b76d8d43172a9
+EBUILD pylint-2.16.4.ebuild 2569 BLAKE2B 2e735782c5ad37ad13b61959b1ed9caac17290935f34cde22e31f4cea9ed6f6a71b4e64875ef65a2d8913a80c3d6a6b5841e5f1c278af0559100c0c53a1bc04b SHA512 6b3c8a7b0669290b1af9c418af4cd96151170e44b597b47680ce3d854817df4b350b903eb77e0ab60b090580588af96d6a148452b0c16a5a0e0b76d8d43172a9
MISC metadata.xml 1100 BLAKE2B 97ec6bd2f6cf487afb93136e9ee58d0d5f8ad37e2ded456ed4f196e73fd37cddead2462d3592b44ca1a6c3722b1f194905238299f0c066945d1e22bdb18acc9b SHA512 0418d987879446fd76fe9b7fc4ee8b1c3c0d9bbab1d1fc3eb66eada0bc52f6b6480cf9852dc3a18b1915d2093642b9c87f24207e89b34d3e48c29a282a3ba979
diff --git a/dev-python/pylint/pylint-2.16.4.ebuild b/dev-python/pylint/pylint-2.16.4.ebuild
new file mode 100644
index 000000000000..6c89d5aea305
--- /dev/null
+++ b/dev-python/pylint/pylint-2.16.4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ https://pypi.org/project/pylint/
+ https://github.com/PyCQA/pylint/
+"
+SRC_URI="
+ https://github.com/pycqa/pylint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+# Make sure to check https://github.com/PyCQA/pylint/blob/main/pyproject.toml#L34 on bumps
+# Adjust dep bounds!
+RDEPEND="
+ <dev-python/astroid-2.16[${PYTHON_USEDEP}]
+ >=dev-python/astroid-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf pylint || die
+
+ local EPYTEST_DESELECT=(
+ # TODO
+ 'tests/test_functional.py::test_functional[forgotten_debug_statement_py37]'
+ 'tests/test_functional.py::test_functional[dataclass_with_field]'
+ 'tests/test_functional.py::test_functional[no_name_in_module]'
+ 'tests/test_functional.py::test_functional[shadowed_import]'
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_error_msg
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_info_msg
+ tests/config/pylint_config/test_run_pylint_config.py::test_invocation_of_pylint_config
+
+ # apparently fragile, needs unpickleable plugin
+ tests/test_check_parallel.py::TestCheckParallelFramework::test_linter_with_unpickleable_plugins_is_pickleable
+ )
+ local EPYTEST_IGNORE=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+ )
+ epytest
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}