summaryrefslogtreecommitdiff
path: root/dev-python/pylint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-24 11:40:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-24 11:40:42 +0000
commita625efe29cec7f7c437cf33a956ea99eed1e4bd9 (patch)
tree3132969a9e093b34d3bd91ee6110a1111a965630 /dev-python/pylint
parent1ff514162358897632ab329134c6bc75af618f10 (diff)
gentoo auto-resync : 24:02:2024 - 11:40:42
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest2
-rw-r--r--dev-python/pylint/pylint-3.0.4.ebuild95
2 files changed, 97 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 7618f96633fb..86311c1d5d97 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,3 +1,5 @@
DIST pylint-3.0.3.gh.tar.gz 1422200 BLAKE2B 999afa1a26cc9fdc8f88bc7a1173c4621f608321b09798de7dd30ef3f5fa295b354ae17acf52009dc340a527f2414f350777ea5893a522f44a31baa466242c63 SHA512 ac5fe236bab08cdacdf9fb78cbf444348bfaa4a359dabd17bfdef5d8a7d9b72a794fd5e7483ea326d1c006668fbd6c37d0aa1f8e7c9963bc75265eb9ced6d43b
+DIST pylint-3.0.4.gh.tar.gz 1423538 BLAKE2B a7ca336831266202f32699b17785fc671222738bdefc2b03dba2a27dde81a193c7d4b51c09d6f6bd61bacaf743dade3ca681c396d64149e1ddd25a897da43952 SHA512 ad674c86a2d52e68e913a92e9e24195c7af185d551b225b6b12b604ca3d9c2e9e3570cff423577dfac66e7af17f48aee2b1807e3973d2e0abba566a85d11e112
EBUILD pylint-3.0.3.ebuild 2396 BLAKE2B c986caa5a26385d265a5a3ebb152b7f3a6570c39f61cddd39acf0ee2acf18c8246b6d66799e809151ccd7eaf819d0d48bb159ee176aa35348d3d7c39bc1ec726 SHA512 bea3b36f79cead5e51b251503c5c28e70abf686be72d18605fe473e81532c8c23bbc8b9bac792f6641dfd516c77b52b851fd9f59a3b2a0c9b02ff9974685a0e4
+EBUILD pylint-3.0.4.ebuild 2445 BLAKE2B a27236b586be59fc8e1843dce0a4c19d96c5dd80bee04f974c5409bf618eab7111cce1da9621d256b11a7675e8e7eee3846a761629ce901cbfd4c75be714937b SHA512 5fe8ae3f87faf85a9288d538d91acc59924779fc7cee21f472db4700f845eb5d576a4d3327bb76634299caaba4546f779f8d0be231563985b9289bba2fbbd528
MISC metadata.xml 1105 BLAKE2B aa9d049b732f9198685901a0ec31f4a615da8398ce1741558e7b2c3840890da0c5ac6a2a23e0fd4cd45fb443b92f69b3fe4fb7f9d7570b1a75a0d0784231f392 SHA512 5f5bb3e31554bdc0cdcdaf1d7df9194e32da649784124714783c5d280c7ab4a9f65317b5d5e6de47698b2f30a019051191cb7ef3066902b606e2582a31f01c05
diff --git a/dev-python/pylint/pylint-3.0.4.ebuild b/dev-python/pylint/pylint-3.0.4.ebuild
new file mode 100644
index 000000000000..036b20dedc71
--- /dev/null
+++ b/dev-python/pylint/pylint-3.0.4.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_P=${P/_beta/b}
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ https://pypi.org/project/pylint/
+ https://github.com/pylint-dev/pylint/
+"
+SRC_URI="
+ https://github.com/pylint-dev/pylint/archive/v${PV/_beta/b}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+# Make sure to check https://github.com/pylint-dev/pylint/blob/main/pyproject.toml#L34 on bumps
+# Adjust dep bounds!
+RDEPEND="
+ <dev-python/astroid-3.1[${PYTHON_USEDEP}]
+ >=dev-python/astroid-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.3.7[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ ' 'python*' )
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ 'tests/test_functional.py::test_functional[dataclass_with_field]'
+
+ # incompatible versions of numpy/scikit-learn?
+ 'tests/test_functional.py::test_functional[no_name_in_module]'
+ 'tests/test_functional.py::test_functional[shadowed_import]'
+ )
+ local EPYTEST_IGNORE=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+ )
+
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ # Requires GitPython
+ EPYTEST_IGNORE+=(
+ tests/profile/test_profile_against_externals.py
+ tests/testutils/_primer/test_package_to_lint.py
+ tests/testutils/_primer/test_primer.py
+ )
+ fi
+
+ rm -rf pylint || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p timeout
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}