summaryrefslogtreecommitdiff
path: root/dev-python/pylint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-18 08:34:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-18 08:34:08 +0100
commit933ed80ab9b645de54b16eeb7410c0a54f47574f (patch)
treed954e8a97c73506c33035766b9578ece5d31667f /dev-python/pylint
parent0b1a4d018ed7758b9e49f6e4b3b38304f91a8cf5 (diff)
gentoo auto-resync : 18:08:2022 - 08:34:07
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest2
-rw-r--r--dev-python/pylint/pylint-2.14.4.ebuild82
2 files changed, 0 insertions, 84 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 2629aecc02ad..fa3a7850060b 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,5 +1,3 @@
-DIST pylint-2.14.4.gh.tar.gz 1275701 BLAKE2B a91dee4c2feb83fb98d0782cd7bbfa81752cc00c707a7b2fbeacf42c6857819d8d4cfffd4caf897af0fd38237d881cfa3b9f57a7e6eb34bee59e0203e3cdd9f3 SHA512 ee305d880052c4e1ebf939201fb5d5d52b642b5130c3314aa91eaad1a413e33e2665a935df1f7a73a3745660de3d3f0a3bed10b2871d840f73bfd2fee651d2b5
DIST pylint-2.14.5.gh.tar.gz 1275994 BLAKE2B 0d490e81f758cca0ff5c4108090414373c3276b3a51f54df26938e128d82b15ca976cb62d999d8b012ce1fe69b56988a385110be02b1d2a281e39d9f91cdb378 SHA512 8c4d2b17c078c305b081e7dd225a1e744420e01b27f63217f80d61e6bcd0e4f8381c94c504cacd3b8f96cc58c3c53d693fb59277ccbd396ea31f6c72af666042
-EBUILD pylint-2.14.4.ebuild 2300 BLAKE2B e24521d06896cfd5307dbed340d1035a182b42d985c59ce6750ea709aaa3658d7d4516e216751b7088c9946dd5bfef15f428c4b0f139cbb2a78731396b3229ac SHA512 3613ba3e532e7be60f89c21775009289e65a536ffae46b742a5e74bffa1f91e8f9d59de831bb479ebef1fea1fe5074816d0f3497f5a047c729b1522bbc357d5d
EBUILD pylint-2.14.5.ebuild 2300 BLAKE2B e24521d06896cfd5307dbed340d1035a182b42d985c59ce6750ea709aaa3658d7d4516e216751b7088c9946dd5bfef15f428c4b0f139cbb2a78731396b3229ac SHA512 3613ba3e532e7be60f89c21775009289e65a536ffae46b742a5e74bffa1f91e8f9d59de831bb479ebef1fea1fe5074816d0f3497f5a047c729b1522bbc357d5d
MISC metadata.xml 1100 BLAKE2B 97ec6bd2f6cf487afb93136e9ee58d0d5f8ad37e2ded456ed4f196e73fd37cddead2462d3592b44ca1a6c3722b1f194905238299f0c066945d1e22bdb18acc9b SHA512 0418d987879446fd76fe9b7fc4ee8b1c3c0d9bbab1d1fc3eb66eada0bc52f6b6480cf9852dc3a18b1915d2093642b9c87f24207e89b34d3e48c29a282a3ba979
diff --git a/dev-python/pylint/pylint-2.14.4.ebuild b/dev-python/pylint/pylint-2.14.4.ebuild
deleted file mode 100644
index 89b5e676d2eb..000000000000
--- a/dev-python/pylint/pylint-2.14.4.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="
- https://pypi.org/project/pylint/
- https://github.com/PyCQA/pylint/
-"
-SRC_URI="
- https://github.com/pycqa/pylint/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="examples"
-
-# Make sure to check https://github.com/PyCQA/pylint/blob/main/pyproject.toml#L34 on bumps
-# Adjust dep bounds!
-RDEPEND="
- <dev-python/astroid-2.12[${PYTHON_USEDEP}]
- >=dev-python/astroid-2.11.6[${PYTHON_USEDEP}]
- >=dev-python/dill-0.2[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- <dev-python/isort-6[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- ' 3.8 3.9)
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
-"
-BDEPEND="
- test? (
- >=dev-python/GitPython-3[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- rm -rf pylint || die
-
- local EPYTEST_DESELECT=(
- # No need to run the benchmarks
- tests/benchmark/test_baseline_benchmarks.py
-
- # TODO
- 'tests/test_functional.py::test_functional[forgotten_debug_statement_py37]'
- 'tests/test_functional.py::test_functional[dataclass_with_field]'
- 'tests/test_functional.py::test_functional[no_name_in_module]'
- tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_error_msg
- tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_info_msg
- tests/config/pylint_config/test_run_pylint_config.py::test_invocation_of_pylint_config
- )
- epytest
-}
-
-python_install_all() {
- if use examples ; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}