summaryrefslogtreecommitdiff
path: root/dev-python/pylint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-26 11:27:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-26 11:27:54 +0100
commit25e2c97a4a6f12a367115508fc86d34fe76a6f5e (patch)
tree68acc191d796190f572dc374002717fec321e616 /dev-python/pylint
parent1aa38370b2506ce90ad64cd4e18968d6612ebea5 (diff)
gentoo auto-resync : 26:09:2023 - 11:27:54
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest2
-rw-r--r--dev-python/pylint/pylint-2.17.6.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 806b557bd0c5..b2ad0de0557a 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,3 +1,5 @@
DIST pylint-2.17.5.gh.tar.gz 1413718 BLAKE2B 7ba0a6cb78cdef5f16e80d98d1b02f41ae700c44365de26a0a650b60fe95b4b806e36786d16ec50ed5c78c8b86c13afe8e7fe215dd938df654c2883d5493d318 SHA512 431e722d027b03f1b657841ccaba43233961e810aecfe1a679e3ba4ba92fea94f28524195861a6fd4fe6fc6267a1af6489b9b69e5e30f919ac3a476fd35698ec
+DIST pylint-2.17.6.gh.tar.gz 1415348 BLAKE2B d760a81cc8a453a081f1b0e3845c5a0b608b8109863665361990da127323c877e8e02ed9c1aca656fa84dd49941b23652fc465177a3e347942047299ebb86a32 SHA512 1e1bba425d295f9d267ef439f4f402dfc7284ee57ac41c222ac39e502c66bbac60c9afb0024ca4236de7cc7130ac733c781f5ee98670fae054005a8d69107123
EBUILD pylint-2.17.5.ebuild 2483 BLAKE2B ce4da2fe18989c31a7bcf2af31a117fda0150f0c0e84cccfae2d39a3a8a00e7b079ea7f872f3c03185941fad03e8b3ace4dd4085d36be73818798d9e0dfea418 SHA512 953d0ef340305f1efa399b2da5983d1838a9502074bd1c0368c2d13815e533d657279016b3c737f36892b6cf552c413e565458dbf64cecb4b1e9d4782f7f0594
+EBUILD pylint-2.17.6.ebuild 2491 BLAKE2B 18c9de8487ecd5eb15e0031da3393b3da4e054a845afb2eda631d736fd68bc5f6b1bb075db44b7d7717d8a4875e8114ce2f7c9fe5162959b5c8b75977b9c3289 SHA512 a411429f28bb0313b1ff947324a6d3951c65544e4f5995f26e4dca39649c4ad6ed03817c61c44bff810c4ebf011cfa9be1b5b5f6268830ae26738c2c251ee8c9
MISC metadata.xml 1105 BLAKE2B aa9d049b732f9198685901a0ec31f4a615da8398ce1741558e7b2c3840890da0c5ac6a2a23e0fd4cd45fb443b92f69b3fe4fb7f9d7570b1a75a0d0784231f392 SHA512 5f5bb3e31554bdc0cdcdaf1d7df9194e32da649784124714783c5d280c7ab4a9f65317b5d5e6de47698b2f30a019051191cb7ef3066902b606e2582a31f01c05
diff --git a/dev-python/pylint/pylint-2.17.6.ebuild b/dev-python/pylint/pylint-2.17.6.ebuild
new file mode 100644
index 000000000000..2880956e4587
--- /dev/null
+++ b/dev-python/pylint/pylint-2.17.6.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ https://pypi.org/project/pylint/
+ https://github.com/pylint-dev/pylint/
+"
+SRC_URI="
+ https://github.com/pylint-dev/pylint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+# Make sure to check https://github.com/pylint-dev/pylint/blob/main/pyproject.toml#L34 on bumps
+# Adjust dep bounds!
+RDEPEND="
+ <dev-python/astroid-2.17[${PYTHON_USEDEP}]
+ >=dev-python/astroid-2.15.7[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf pylint || die
+
+ local EPYTEST_DESELECT=(
+ # TODO
+ 'tests/test_functional.py::test_functional[forgotten_debug_statement_py37]'
+ 'tests/test_functional.py::test_functional[dataclass_with_field]'
+ 'tests/test_functional.py::test_functional[no_name_in_module]'
+ 'tests/test_functional.py::test_functional[shadowed_import]'
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_error_msg
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_info_msg
+ tests/config/pylint_config/test_run_pylint_config.py::test_invocation_of_pylint_config
+
+ # apparently fragile, needs unpickleable plugin
+ tests/test_check_parallel.py::TestCheckParallelFramework::test_linter_with_unpickleable_plugins_is_pickleable
+ )
+ local EPYTEST_IGNORE=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+ )
+ epytest
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}