summaryrefslogtreecommitdiff
path: root/dev-python/pylint/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-python/pylint/files
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-python/pylint/files')
-rw-r--r--dev-python/pylint/files/pylint-2.5.3-no-pytest-runner.patch20
-rw-r--r--dev-python/pylint/files/pylint-2.5.3-tests.patch12
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pylint/files/pylint-2.5.3-no-pytest-runner.patch b/dev-python/pylint/files/pylint-2.5.3-no-pytest-runner.patch
new file mode 100644
index 000000000000..f4cc6be360de
--- /dev/null
+++ b/dev-python/pylint/files/pylint-2.5.3-no-pytest-runner.patch
@@ -0,0 +1,20 @@
+diff --git a/setup.py b/setup.py
+index 92d059ff..cbc5b881 100644
+--- a/setup.py
++++ b/setup.py
+@@ -67,7 +67,6 @@ else:
+
+
+ needs_pytest = {"pytest", "test", "ptr"}.intersection(sys.argv)
+-pytest_runner = ["pytest-runner"] if needs_pytest else []
+
+
+ def ensure_scripts(linux_scripts):
+@@ -151,7 +150,6 @@ def install(**kwargs):
+ extras_require=extras_require,
+ test_suite="test",
+ python_requires=">=3.5.*",
+- setup_requires=pytest_runner,
+ tests_require=["pytest"],
+ **kwargs
+ )
diff --git a/dev-python/pylint/files/pylint-2.5.3-tests.patch b/dev-python/pylint/files/pylint-2.5.3-tests.patch
new file mode 100644
index 000000000000..72a42e4caaeb
--- /dev/null
+++ b/dev-python/pylint/files/pylint-2.5.3-tests.patch
@@ -0,0 +1,12 @@
+diff --git a/tests/test_self.py b/tests/test_self.py
+index 6c27fd6c..9fde0214 100644
+--- a/tests/test_self.py
++++ b/tests/test_self.py
+@@ -686,6 +686,7 @@ class TestRunTC:
+ )
+
+ @staticmethod
++ @pytest.mark.skip("seems to be failing to import nonexistant module")
+ def test_do_not_import_files_from_local_directory(tmpdir):
+ p_astroid = tmpdir / "astroid.py"
+ p_astroid.write("'Docstring'\nimport completely_unknown\n")