summaryrefslogtreecommitdiff
path: root/dev-python/pylint/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /dev-python/pylint/files
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'dev-python/pylint/files')
-rw-r--r--dev-python/pylint/files/pylint-2.4.4-no-pytest-runner.patch12
-rw-r--r--dev-python/pylint/files/pylint-2.4.4-sphinx-theme.patch13
-rw-r--r--dev-python/pylint/files/pylint-2.4.4-tests.patch13
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pylint/files/pylint-2.4.4-no-pytest-runner.patch b/dev-python/pylint/files/pylint-2.4.4-no-pytest-runner.patch
new file mode 100644
index 000000000000..0d668d01cdc9
--- /dev/null
+++ b/dev-python/pylint/files/pylint-2.4.4-no-pytest-runner.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index 4d16b79b..b2a1b9e9 100644
+--- a/setup.py
++++ b/setup.py
+@@ -143,7 +143,6 @@ def install(**kwargs):
+ extras_require=extras_require,
+ test_suite="test",
+ python_requires=">=3.5.*",
+- setup_requires=["pytest-runner"],
+ tests_require=["pytest"],
+ **kwargs
+ )
diff --git a/dev-python/pylint/files/pylint-2.4.4-sphinx-theme.patch b/dev-python/pylint/files/pylint-2.4.4-sphinx-theme.patch
new file mode 100644
index 000000000000..1a84400a8d78
--- /dev/null
+++ b/dev-python/pylint/files/pylint-2.4.4-sphinx-theme.patch
@@ -0,0 +1,13 @@
+diff --git a/doc/conf.py b/doc/conf.py
+index 906f0315..caca0c0c 100644
+--- a/doc/conf.py
++++ b/doc/conf.py
+@@ -100,7 +100,7 @@ pygments_style = "sphinx"
+
+ # The theme to use for HTML and HTML Help pages. See the documentation for
+ # a list of builtin themes.
+-html_theme = "python_docs_theme"
++html_theme = "nature"
+
+ # Theme options are theme-specific and customize the look and feel of a theme
+ # further. For a list of options available for each theme, see the
diff --git a/dev-python/pylint/files/pylint-2.4.4-tests.patch b/dev-python/pylint/files/pylint-2.4.4-tests.patch
new file mode 100644
index 000000000000..b11ecb7c505b
--- /dev/null
+++ b/dev-python/pylint/files/pylint-2.4.4-tests.patch
@@ -0,0 +1,13 @@
+diff --git a/tests/unittest_lint.py b/tests/unittest_lint.py
+index 4f942cd0..d54008bf 100644
+--- a/tests/unittest_lint.py
++++ b/tests/unittest_lint.py
+@@ -792,7 +792,7 @@ def test_filename_with__init__(init_linter):
+ messages = reporter.messages
+ assert len(messages) == 0
+
+-
++@pytest.mark.skip("known failure, see https://github.com/PyCQA/pylint/issues/3198")
+ def test_by_module_statement_value(init_linter):
+ """Test "statement" for each module analized of computed correctly."""
+ linter = init_linter