summaryrefslogtreecommitdiff
path: root/dev-python/pylint-venv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
commitdb70871b2044b9bfde346d6f4027dafb0a013c4c (patch)
tree34548aee54e5458d3754bd8c8f987acdb5ee444c /dev-python/pylint-venv
parent1c382dc5dbc52576ac2300fee0498af8af44e7b4 (diff)
gentoo auto-resync : 15:06:2023 - 13:38:09
Diffstat (limited to 'dev-python/pylint-venv')
-rw-r--r--dev-python/pylint-venv/Manifest2
-rw-r--r--dev-python/pylint-venv/pylint-venv-3.0.2.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pylint-venv/Manifest b/dev-python/pylint-venv/Manifest
index 2719ce4f43a8..53fa161c36b4 100644
--- a/dev-python/pylint-venv/Manifest
+++ b/dev-python/pylint-venv/Manifest
@@ -1,3 +1,5 @@
DIST pylint-venv-3.0.1.gh.tar.gz 14901 BLAKE2B e41a0782fe1bdf83b0019c035cb80416838b71924a1574189aa8936a22fce689523984a277305beba49559d0bcdbde9c8b4ac6a9cb12e1a3853a9a3f287a7a57 SHA512 7b6e7be85dd5552c99d620550e602eb908fccb1ef0982e1734276e14f882261ad7c13309ac796e657865544484a275016981e9b75ef31d17d4c01454b7e091a8
+DIST pylint-venv-3.0.2.gh.tar.gz 15046 BLAKE2B 3c07e00739541c4b9b7c28c9b6cf91e8dee27885adcac8ec88b347f6c580ee0a0c905271eb5b5256ccf0ea975604bf98560ce271a27cbfd2d5790d1143ba6af4 SHA512 716491ffbb5e6642cd61cee62c720a594d85b4cf44feb2d53d3e120dbdea813234776a95341ac10acbdd64354cc3875659f1d3bbc5f45a87ac5232e1e7f89473
EBUILD pylint-venv-3.0.1.ebuild 917 BLAKE2B f443a4e7e6841de84b0d5332f1c840efbf81654ffa46374eb7ff3a2384b1add349187e610fcbbf9fa12c0af7b5e58b8300e1f35343d4dec84116149e35b7de80 SHA512 992bc66055bd4f1ee4e959ed48f54073b3d180c80553a784353e517fc17692722780591fb747e832a7782dc6b343d24fc7683c30223f28ab9dbec8d391f6ed8c
+EBUILD pylint-venv-3.0.2.ebuild 918 BLAKE2B f48ac18775a4d4f1fda88f53023288cc3877d656a9012aa24981faa4d545eb0a14bbacab706215b5022d509c37478e33d15a1162824752839234a3624f5e0440 SHA512 ec9f890f8a683186cf1c387fefe6086f294b389d2990f74d708ba197abd620f088a619675122a101d0fc0392161c2bd812fd533fba9d4f57b3982062b391d3e4
MISC metadata.xml 412 BLAKE2B 8dc1e28ad5e2b21a9483906e776a96d598e294fbc4dbf669ecea9357055b1a7439e0046353ab39b3c2bfaab7924f43a89c309db735e44a00838dd1bed2f5c088 SHA512 4e7963aa4cdcc168bd4755f21cb58cb084c185e1c71ef9fdfe168feb1ec65fc4848c99801e449f253e420b9e34d49aab396d2e02bb60a7cbd3733dd2a899c6cd
diff --git a/dev-python/pylint-venv/pylint-venv-3.0.2.ebuild b/dev-python/pylint-venv/pylint-venv-3.0.2.ebuild
new file mode 100644
index 000000000000..02d3f783d513
--- /dev/null
+++ b/dev-python/pylint-venv/pylint-venv-3.0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Init-hook to use the same Pylint with different virtual environments"
+HOMEPAGE="
+ https://pypi.org/project/pylint-venv/
+ https://github.com/jgosmann/pylint-venv/
+"
+SRC_URI="
+ https://github.com/jgosmann/pylint-venv/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pylint-2.14.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pylint-2.14.0[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ # we need to set PYTHONPATH explicitly since the test runs installed
+ # pylint (i.e. starts outside the test venv)
+ local -x PYTHONPATH=${S}:${PYTHONPATH}
+ bash test/test.sh || die "Test failed with ${EPYTHON}"
+}