summaryrefslogtreecommitdiff
path: root/dev-python/pylint-venv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-23 09:44:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-23 09:44:00 +0000
commit8d15cb8238a384acdb70250a0cd213f2ab5f0ab6 (patch)
tree547dd4d959be6b14e702d37e94063dc2104319a5 /dev-python/pylint-venv
parent71fb24e4cc15fe73651423df81c5e6a79fa8c142 (diff)
gentoo auto-resync : 23:02:2023 - 09:44:00
Diffstat (limited to 'dev-python/pylint-venv')
-rw-r--r--dev-python/pylint-venv/Manifest2
-rw-r--r--dev-python/pylint-venv/pylint-venv-3.0.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pylint-venv/Manifest b/dev-python/pylint-venv/Manifest
index 5804b3cf26b1..e6a0a38253a5 100644
--- a/dev-python/pylint-venv/Manifest
+++ b/dev-python/pylint-venv/Manifest
@@ -1,3 +1,5 @@
DIST pylint-venv-2.3.0.gh.tar.gz 4967 BLAKE2B 7095848b28f1128d44164fecbd1fd1c3694140d8b3818fefcab92aa5a4083608dfc36c96a6c30b117a8592bea0de9b92a537c33f8db4ce8c1285a575d1aa2131 SHA512 c3f9294a137cc6369984cf714196ee0a248471990f2c6e691da86f3048126b99775cc8e9c516c72bd8746d0d814a52387eca165c5f1960aa418ec5abb13a3bed
+DIST pylint-venv-3.0.0.gh.tar.gz 14757 BLAKE2B 807b0e6eb7fee32d592fc215a6c4018003078f66c3500ffb9e9769e98e2226554433f2ae33f6480ae4240e8e96b932df23f8ddc3b3dab5bdd54cff3509f9ba48 SHA512 d239919a42f5107de255cc8de0737bbf57798f949f6845cad13da2fa30ded05ad07319b6294d19fe866ea0d533b3a30ba0f064a9c1091ac39ace6d9998f0f5df
EBUILD pylint-venv-2.3.0.ebuild 567 BLAKE2B 4eb68ff151974107b70067b2e1cf25bdf9955c75eef278ac7a6ed2661e9ed3a501899570fe9aa6d42d9a563049270af09d47ab2cc29599b5a63b15ed516641c5 SHA512 dde267ef4ffa3365c148b7b5fc5b9e348c7f832db5699ed31ec2b0895014ccb6d5a1cd6bccd6ded12a46598ee89b7d331cee02011e675c2c26a9534af50b70ad
+EBUILD pylint-venv-3.0.0.ebuild 853 BLAKE2B b8f77ffb77e3b48c9b1165bde772d2216807949681da0934b15f5b87abc097eaf380f7c06de8ab087f46e9c2f0d40861093a05b334146c6d2e8abd33b249221e SHA512 d72eff40c46deead0f4643da5a95aea83cb773ea19566b659bf3f3db61495760dfd52e0fcf522078a5239c848e742480b93cc28b6837a4e6f791ee70a6001976
MISC metadata.xml 412 BLAKE2B 8dc1e28ad5e2b21a9483906e776a96d598e294fbc4dbf669ecea9357055b1a7439e0046353ab39b3c2bfaab7924f43a89c309db735e44a00838dd1bed2f5c088 SHA512 4e7963aa4cdcc168bd4755f21cb58cb084c185e1c71ef9fdfe168feb1ec65fc4848c99801e449f253e420b9e34d49aab396d2e02bb60a7cbd3733dd2a899c6cd
diff --git a/dev-python/pylint-venv/pylint-venv-3.0.0.ebuild b/dev-python/pylint-venv/pylint-venv-3.0.0.ebuild
new file mode 100644
index 000000000000..ad1160f14a79
--- /dev/null
+++ b/dev-python/pylint-venv/pylint-venv-3.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Init-hook to use the same Pylint with different virtual environments"
+HOMEPAGE="
+ https://pypi.org/project/pylint-venv/
+ https://github.com/jgosmann/pylint-venv/
+"
+SRC_URI="
+ https://github.com/jgosmann/pylint-venv/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pylint-2.14.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pylint-2.14.0[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ sed -i -e 's:which:echo:' test/test.sh || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ bash test/test.sh || die "Test failed with ${EPYTHON}"
+}