summaryrefslogtreecommitdiff
path: root/dev-python/pylint-venv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-07 15:22:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-07 15:22:09 +0000
commit441369caa3d11703d0349d4b9746b7ad10aa6cb2 (patch)
tree5d36ced6c5c7c609bcca67e1cfe9f4125237185f /dev-python/pylint-venv
parent85ba3f2cfe9ff2b952efb1f3c3c08840f8093246 (diff)
gentoo auto-resync : 07:11:2022 - 15:22:08
Diffstat (limited to 'dev-python/pylint-venv')
-rw-r--r--dev-python/pylint-venv/Manifest3
-rw-r--r--dev-python/pylint-venv/metadata.xml13
-rw-r--r--dev-python/pylint-venv/pylint-venv-2.3.0.ebuild27
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pylint-venv/Manifest b/dev-python/pylint-venv/Manifest
new file mode 100644
index 000000000000..ef884eb153e8
--- /dev/null
+++ b/dev-python/pylint-venv/Manifest
@@ -0,0 +1,3 @@
+DIST pylint-venv-2.3.0.gh.tar.gz 4967 BLAKE2B 7095848b28f1128d44164fecbd1fd1c3694140d8b3818fefcab92aa5a4083608dfc36c96a6c30b117a8592bea0de9b92a537c33f8db4ce8c1285a575d1aa2131 SHA512 c3f9294a137cc6369984cf714196ee0a248471990f2c6e691da86f3048126b99775cc8e9c516c72bd8746d0d814a52387eca165c5f1960aa418ec5abb13a3bed
+EBUILD pylint-venv-2.3.0.ebuild 567 BLAKE2B cdfd2974f482ec9419a6a035279905706ed5ae8df7d4b840b7edb0e1e0f99e4b3b08535d6eec8b355c32158ef010f47a5047ca48437862aeac3dcc2d8067f9cb SHA512 83e411628752cf4e6d6893e3c9f99e2222340960124ea6410e59811d166aac136f67005b743f12e598147f668f250d6ad986248d0d773e45a3875a0179af1e96
+MISC metadata.xml 412 BLAKE2B 8dc1e28ad5e2b21a9483906e776a96d598e294fbc4dbf669ecea9357055b1a7439e0046353ab39b3c2bfaab7924f43a89c309db735e44a00838dd1bed2f5c088 SHA512 4e7963aa4cdcc168bd4755f21cb58cb084c185e1c71ef9fdfe168feb1ec65fc4848c99801e449f253e420b9e34d49aab396d2e02bb60a7cbd3733dd2a899c6cd
diff --git a/dev-python/pylint-venv/metadata.xml b/dev-python/pylint-venv/metadata.xml
new file mode 100644
index 000000000000..7aad6578435c
--- /dev/null
+++ b/dev-python/pylint-venv/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pylint-venv</remote-id>
+ <remote-id type="github">jgosmann/pylint-venv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pylint-venv/pylint-venv-2.3.0.ebuild b/dev-python/pylint-venv/pylint-venv-2.3.0.ebuild
new file mode 100644
index 000000000000..b609a2267b22
--- /dev/null
+++ b/dev-python/pylint-venv/pylint-venv-2.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Init-hook to use the same Pylint with different virtual environments"
+HOMEPAGE="
+ https://pypi.org/project/pylint-venv/
+ https://github.com/jgosmann/pylint-venv/
+"
+SRC_URI="
+ https://github.com/jgosmann/pylint-venv/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pylint[${PYTHON_USEDEP}]
+"