summaryrefslogtreecommitdiff
path: root/dev-python/pylint-venv/pylint-venv-3.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-24 09:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-24 09:47:15 +0000
commit4003c614d3c4b320c45ab1f4b817459d4709443b (patch)
treefcc0c42e92c56abe0ea39b717b2c3b019c335e41 /dev-python/pylint-venv/pylint-venv-3.0.1.ebuild
parent58177544118b9a8393d7501ee5e0e35cd32f2ad4 (diff)
gentoo auto-resync : 24:02:2023 - 09:47:15
Diffstat (limited to 'dev-python/pylint-venv/pylint-venv-3.0.1.ebuild')
-rw-r--r--dev-python/pylint-venv/pylint-venv-3.0.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pylint-venv/pylint-venv-3.0.1.ebuild b/dev-python/pylint-venv/pylint-venv-3.0.1.ebuild
new file mode 100644
index 000000000000..b1d01e98259b
--- /dev/null
+++ b/dev-python/pylint-venv/pylint-venv-3.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Init-hook to use the same Pylint with different virtual environments"
+HOMEPAGE="
+ https://pypi.org/project/pylint-venv/
+ https://github.com/jgosmann/pylint-venv/
+"
+SRC_URI="
+ https://github.com/jgosmann/pylint-venv/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pylint-2.14.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pylint-2.14.0[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ # we need to set PYTHONPATH explicitly since the test runs installed
+ # pylint (i.e. starts outside the test venv)
+ local -x PYTHONPATH=${S}:${PYTHONPATH}
+ bash test/test.sh || die "Test failed with ${EPYTHON}"
+}