summaryrefslogtreecommitdiff
path: root/dev-python/pylibacl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-16 00:13:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-16 00:13:18 +0000
commitf2bdc27fe0f79f8f9a3945eb2b1163ce75c56439 (patch)
treedd0f7da0455831dffb2cb662e7dae760f92e68ad /dev-python/pylibacl
parent770d63f36dbe1722e0ff9ab55eeca49986f01527 (diff)
gentoo auto-resync : 16:02:2025 - 00:13:18
Diffstat (limited to 'dev-python/pylibacl')
-rw-r--r--dev-python/pylibacl/Manifest2
-rw-r--r--dev-python/pylibacl/pylibacl-0.7.1.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pylibacl/Manifest b/dev-python/pylibacl/Manifest
index 3c844511966f..5137160aa1eb 100644
--- a/dev-python/pylibacl/Manifest
+++ b/dev-python/pylibacl/Manifest
@@ -1,3 +1,5 @@
DIST pylibacl-0.7.0.tar.gz 47543 BLAKE2B 277c03d01ab184ffaaa2c07c56e8f2464cba8b6da0fbd251880d274bef3b27dc211f1571425d4216e02bbeba8c623edfa56cafbb27932092ffce254e6be8df5d SHA512 077515a00c7a048faf7792acd9c3e768d35674c0b3f4ec72fdf37561c90ed12bb392582a4fb9a23b7916db3375278c2636f2844f362a8335e7ad68e1e9b9c3bd
+DIST pylibacl-0.7.1.tar.gz 49017 BLAKE2B bafdb70bc9971fd41303be7f039b7767edd081136d25547919f88bf44308068b04ca60d05740f5d7ba5f67666b2b17d43e2493fe4f4a93db809f3d3bb06f1080 SHA512 8faba30ba90bed5219519394062fbfec0e0ad0f7bfa45769334f75b3899baa56a676b5ea0b06d13c7f60b5af1850621c34654d08ccc07aaafd645407d1fd9070
EBUILD pylibacl-0.7.0.ebuild 950 BLAKE2B 66f1e9f7c1490c19f756c9d9fd09cf7924d9d4c8d9436a5e23449e78538033b162ff35ab0c0e657d4ae2a9054a8a5c83b666f602784bfaa9b88fbd6890bbd0e4 SHA512 6b4a2a0d5339a1ef827e3eb3ed39d238f1b1d45d4758c038b50eab9a2240babceac60844f0b7d513c3765fa0ad99d77cf741aab71ef5d6baa9c0f7a400fd2b8b
+EBUILD pylibacl-0.7.1.ebuild 956 BLAKE2B 2e046c12e357de2b54148e66d295a9f868a9bce13eedb8154f33c785de7ceb9d7afce4a9b4f2741332046a45ec5e967a7dba6448cb93b741ab5b73aa26dc49f5 SHA512 3aed3479e1487c72601d2d3db49094b8c73a65f2c94e515021662e11b95400d41135bc531d9d3a3f0740fbd523a71b1314788bdc7a3468bcb78025fabc19efcc
MISC metadata.xml 446 BLAKE2B 0e111cfd834a03f88984dac937b5b3d09a7675338f0381d30603b0512d7f5ae1f486a832d060ecfb9c5946c7273893ed030555062b8bd3f26f10765c28a90143 SHA512 7df5bf16220e50c851fb03af84a600eaba23fdb703aefc2586aa2d27a1e55a18ad7b117274b8a07c7d7997dfd96fd51bd2dca6d3a1dad01cacafa678a5c8a794
diff --git a/dev-python/pylibacl/pylibacl-0.7.1.ebuild b/dev-python/pylibacl/pylibacl-0.7.1.ebuild
new file mode 100644
index 000000000000..68025f74006e
--- /dev/null
+++ b/dev-python/pylibacl/pylibacl-0.7.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="POSIX ACLs (Access Control Lists) for Python"
+HOMEPAGE="
+ https://pylibacl.k1024.org/
+ https://pypi.org/project/pylibacl/
+ https://github.com/iustin/pylibacl/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ sys-apps/acl
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_sphinx doc \
+ dev-python/recommonmark
+distutils_enable_tests pytest
+
+python_test() {
+ if ! nonfatal epytest ; then
+ eerror
+ eerror "If you got the following errors:"
+ eerror "\"IOError: [Errno 95] Operation not supported\","
+ eerror "then you should remount the filesystem containing"
+ eerror "build directory with \"acl\" option enabled."
+ eerror
+ die "Tests fail with ${EPYTHON}"
+ fi
+}