summaryrefslogtreecommitdiff
path: root/dev-python/pylibacl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pylibacl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pylibacl')
-rw-r--r--dev-python/pylibacl/Manifest3
-rw-r--r--dev-python/pylibacl/metadata.xml14
-rw-r--r--dev-python/pylibacl/pylibacl-0.5.0-r1.ebuild36
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pylibacl/Manifest b/dev-python/pylibacl/Manifest
new file mode 100644
index 000000000000..60065d3db093
--- /dev/null
+++ b/dev-python/pylibacl/Manifest
@@ -0,0 +1,3 @@
+DIST pylibacl-0.5.0.tar.gz 23886 BLAKE2B fdc447701d2856a460ad6cf5d4a31e9334cf5cda668af7d44c780bfb3320d2aa9d58e44d43d2b43b134a9fbac76d657a03f9190fd0c8ce1b6f4061da93cee56a SHA512 c12390b6a0ca73fd351b84860a9d68d74126dbcd8656916d677a39002a6e4abbac704d450b0b0118bba40987cdd11cc11ad14008de39dac8dc9ca7587ae54c46
+EBUILD pylibacl-0.5.0-r1.ebuild 940 BLAKE2B 2dcb65037a2a2950dc978ec862a18308003564699b2a9cc2cd5ebce2ebf4b3d541974210ea88dd4e0ca048cdf57ce3ef2f1bae5d1304986075e7a42133ceb1d3 SHA512 7321f5b50b82a7fb93b583bc4a16367a26780dd59230720a6828c8110931446147d0d87f526cfa1190945ad3af80ea024b6f8e5fec3fbaca50459222c783bb86
+MISC metadata.xml 397 BLAKE2B 02cd4a3738c4cd458353daa57d96877602717591300d2146d4953734fe37a274250ab07b786ee68160f91cb6a399edd11495e338ca0ed991bc82351f3219ad26 SHA512 c180079a6f20e899a3fe472db2e91c36ae7cf9d67f519dea0f2367aaa7febe3123374d3f5bb847267b5b42e234fe1548208db0eee20cf520ff5eb9b9cc699696
diff --git a/dev-python/pylibacl/metadata.xml b/dev-python/pylibacl/metadata.xml
new file mode 100644
index 000000000000..6112c9d184b0
--- /dev/null
+++ b/dev-python/pylibacl/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">pylibacl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pylibacl/pylibacl-0.5.0-r1.ebuild b/dev-python/pylibacl/pylibacl-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..68a573ccb991
--- /dev/null
+++ b/dev-python/pylibacl/pylibacl-0.5.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="POSIX ACLs (Access Control Lists) for Python"
+HOMEPAGE="https://pylibacl.k1024.org/
+ https://pypi.org/project/pylibacl/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~sh sparc x86"
+IUSE=""
+
+RDEPEND="sys-apps/acl"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+# Tests are missing in the tarball.
+RESTRICT="test"
+
+python_test() {
+ if ! "${PYTHON}" test/test_acls.py; then
+ eerror
+ eerror "If you got the following errors:"
+ eerror "\"IOError: [Errno 95] Operation not supported\","
+ eerror "then you should remount the filesystem containing"
+ eerror "build directory with \"acl\" option enabled."
+ eerror
+ die "Tests fail with ${EPYTHON}"
+ fi
+}